summaryrefslogtreecommitdiff
path: root/sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch')
-rw-r--r--sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch b/sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch
new file mode 100644
index 000000000000..2f19725a6e10
--- /dev/null
+++ b/sci-libs/rocSPARSE/files/rocSPARSE-4.3.0-remove-matrices-unpacking.patch
@@ -0,0 +1,36 @@
+Don't let cmake handle test data download, unpack and convert
+
+--- orig/clients/tests/CMakeLists.txt
++++ rocSPARSE-rocm-4.3.0/clients/tests/CMakeLists.txt
+@@ -23,31 +23,6 @@
+
+ find_package(GTest 1.10.0 REQUIRED)
+
+-#
+-# Client matrices.
+-#
+-if(NOT EXISTS "${CMAKE_MATRICES_DIR}")
+- #
+- # Download.
+- #
+- set(CMAKE_MATRICES_DIR ${PROJECT_BINARY_DIR}/matrices CACHE STRING "Matrices directory.")
+-
+- if(NOT TARGET rocsparse)
+- set(CONVERT ${CMAKE_SOURCE_DIR}/../deps/convert CACHE STRING "Convert tool mtx2csr.")
+- include(${CMAKE_SOURCE_DIR}/../cmake/ClientMatrices.cmake)
+- else()
+- set(CONVERT ${CMAKE_SOURCE_DIR}/deps/convert CACHE STRING "Convert tool mtx2csr.")
+- include(${CMAKE_SOURCE_DIR}/cmake/ClientMatrices.cmake)
+- endif()
+-
+-else()
+-
+- #
+- # Copy.
+- #
+- execute_process(COMMAND cp -r ${CMAKE_MATRICES_DIR} ${PROJECT_BINARY_DIR}/matrices)
+-
+-endif()
+
+ set(ROCSPARSE_TEST_SOURCES
+ test_axpby.cpp