summaryrefslogtreecommitdiff
path: root/sci-libs/qd/qd-2.3.23.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/qd/qd-2.3.23.ebuild')
-rw-r--r--sci-libs/qd/qd-2.3.23.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/qd/qd-2.3.23.ebuild b/sci-libs/qd/qd-2.3.23.ebuild
new file mode 100644
index 000000000000..d3c5bfd71d45
--- /dev/null
+++ b/sci-libs/qd/qd-2.3.23.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED=fortran
+
+inherit autotools fortran-2
+
+DESCRIPTION="Quad-double and double-double float arithmetics"
+HOMEPAGE="https://www.davidhbailey.com/dhbsoftware/"
+SRC_URI="https://www.davidhbailey.com/dhbsoftware/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_fma3 cpu_flags_x86_fma4 doc fortran"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-ieee-add \
+ --disable-sloppy-mul \
+ --disable-sloppy-div \
+ --enable-inline \
+ $(use_enable cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4) fma) \
+ $(use_enable fortran)
+}
+
+src_install() {
+ default
+
+ dosym qd_real.h /usr/include/qd/qd.h
+ dosym dd_real.h /usr/include/qd/dd.h
+
+ if ! use doc; then
+ rm "${ED}"/usr/share/doc/${PF}/*.pdf || die
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}