summaryrefslogtreecommitdiff
path: root/sci-libs/profnet
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/profnet')
-rw-r--r--sci-libs/profnet/Manifest2
-rw-r--r--sci-libs/profnet/profnet-1.0.22.ebuild14
2 files changed, 10 insertions, 6 deletions
diff --git a/sci-libs/profnet/Manifest b/sci-libs/profnet/Manifest
index ff60d88bc798..b343c4e2d63f 100644
--- a/sci-libs/profnet/Manifest
+++ b/sci-libs/profnet/Manifest
@@ -1,3 +1,3 @@
DIST profnet-1.0.22.tar.gz 203676 BLAKE2B ecee0347d711784c37b71cc3b0812bbd871d2438716a4fa2fb1e2b9c1fe3a9801073fcff3432203feed226325db36d4246d0be64487c57f2f643a192ae33840e SHA512 11c6d180219b60df7c5e144719354b7fbd5845e4ab6e52027315ee80d820c89fca9bce5b9e9e49314aa64058f93196f0cd35089604b53721fee3c050e45d9555
-EBUILD profnet-1.0.22.ebuild 660 BLAKE2B 2b0c724f2c9d33f14ed7a72e60562f4fa15efcff97f69474073755927726c434e92e81a341eb6af17bf421fab914a4b9e06af313fde06be8ee0ece13d3b3da2f SHA512 89452bb3149a8124ccd60d866ae0afc6c1132126d83d33f2aefe53a3179a4f51fd90885cbf93eda417527ea6874c73daf511eb713cc27d390c0690150517ff94
+EBUILD profnet-1.0.22.ebuild 844 BLAKE2B ad85ec69fb1b95d081ae97a4cae612c82310cc52114cd3c86e9c489e2bd03b837c5f9b59cfc6e7a1f41751832c64dc5f6f0a55ec8af2cb5a5e5b62b87a3cb98a SHA512 d169cd5861636652395a8a83e068ff26ff838637780224137f48e1a3db00ee271e47f11a6d0552c95f061e6a8f83ef41519acdbda705deae56a1ecc90b680d96
MISC metadata.xml 267 BLAKE2B 7cf386952842945148119de3263231db4d1046d5f54811f7e303ed8ec4d27cbc1960b99c92daf6f32e5b981c2fb9f50ec666be6193865d6e18541b7427a152a9 SHA512 91ab266d9ab24401bc0fec759c5b6cfcf44a3c5669fc31c7301d79770839bb5dfa0e155d949392ef06176b4a0b2c32b91b1b54b0027f972db61f0a5e54644403
diff --git a/sci-libs/profnet/profnet-1.0.22.ebuild b/sci-libs/profnet/profnet-1.0.22.ebuild
index df450e7e8d39..5488f1435dec 100644
--- a/sci-libs/profnet/profnet-1.0.22.ebuild
+++ b/sci-libs/profnet/profnet-1.0.22.ebuild
@@ -1,29 +1,30 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit fortran-2 toolchain-funcs
+inherit flag-o-matic fortran-2 toolchain-funcs
DESCRIPTION="Neural network architecture for profacc"
HOMEPAGE="https://rostlab.org/"
SRC_URI="ftp://rostlab.org/profnet/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-3"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="sys-libs/libunwind"
DEPEND="${RDEPEND}"
src_prepare() {
+ default
sed \
-e '/$@/s:-o:$(LDFLAGS) -o:g' \
-i src-phd/Makefile || die
}
src_compile() {
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
emake \
F77=$(tc-getF77) \
FFLAGS="${FFLAGS}"
@@ -34,4 +35,7 @@ src_install() {
DESTDIR="${D}" \
prefix="${EPREFIX}/usr" \
install
+
+ # Don't install compressed man pages
+ find "${ED}"/usr/share/man -type f -name '*.gz' -exec gzip -d {} \; || die
}