summaryrefslogtreecommitdiff
path: root/sci-libs/pdal/files/pdal-2.3.0-upgrade_cmake_min.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/pdal/files/pdal-2.3.0-upgrade_cmake_min.patch')
-rw-r--r--sci-libs/pdal/files/pdal-2.3.0-upgrade_cmake_min.patch77
1 files changed, 0 insertions, 77 deletions
diff --git a/sci-libs/pdal/files/pdal-2.3.0-upgrade_cmake_min.patch b/sci-libs/pdal/files/pdal-2.3.0-upgrade_cmake_min.patch
deleted file mode 100644
index 9b712cb0e789..000000000000
--- a/sci-libs/pdal/files/pdal-2.3.0-upgrade_cmake_min.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
-index 8dd8845f35..c4b7e37543 100644
---- a/apps/CMakeLists.txt
-+++ b/apps/CMakeLists.txt
-@@ -3,7 +3,7 @@
- #
- # (based originally on the libLAS files copyright Mateusz Loskot)
-
--cmake_minimum_required(VERSION 2.8)
-+cmake_minimum_required(VERSION 3.5)
-
- #------------------------------------------------------------------------------
- # Configure build targets
-diff --git a/cmake/ctest.cmake b/cmake/ctest.cmake
-index a8382aaef5..98035205d1 100644
---- a/cmake/ctest.cmake
-+++ b/cmake/ctest.cmake
-@@ -5,7 +5,7 @@ if(ENABLE_CTEST)
- if (WITH_TESTS)
- message(STATUS
- "Enable CTest to support submissions of results to CDash at http://cdash.org")
-- cmake_minimum_required(VERSION 2.8.0)
-+ cmake_minimum_required(VERSION 3.5.0)
- #
- # Dashboard has been prepared for experiments
- # http://my.cdash.org/index.php?project=PDAL
-diff --git a/dimbuilder/CMakeLists.txt b/dimbuilder/CMakeLists.txt
-index 09d334f1f8..9aa9742f63 100644
---- a/dimbuilder/CMakeLists.txt
-+++ b/dimbuilder/CMakeLists.txt
-@@ -2,7 +2,7 @@
- # The seemingly strange arrangement of this cmake file allows you to build
- # this application as a standalone.
- #
--cmake_minimum_required(VERSION 2.8.6)
-+cmake_minimum_required(VERSION 3.5)
-
- set(MAKE_COLOR_MAKEFILE ON)
-
-diff --git a/plugins/rdb/CMakeLists.txt b/plugins/rdb/CMakeLists.txt
-index 2ec0adcf92..2e8ae422de 100644
---- a/plugins/rdb/CMakeLists.txt
-+++ b/plugins/rdb/CMakeLists.txt
-@@ -1,6 +1,6 @@
-
- if (STANDALONE)
--cmake_minimum_required(VERSION 3.1)
-+cmake_minimum_required(VERSION 3.5)
- set(ROOT_DIR "../../${PROJECT_SOURCE_DIR}")
- include(../../cmake/common.cmake NO_POLICY_SCOPE)
- include(FeatureSummary)
-diff --git a/tools/lasdump/CMakeLists.txt b/tools/lasdump/CMakeLists.txt
-index 8083a228d8..767d642e76 100644
---- a/tools/lasdump/CMakeLists.txt
-+++ b/tools/lasdump/CMakeLists.txt
-@@ -2,7 +2,7 @@
- # The seemingly strange arrangement of this cmake file allows you to build
- # lasdump as a standalone.
- #
--cmake_minimum_required(VERSION 2.8.6)
-+cmake_minimum_required(VERSION 3.5)
-
- set(MAKE_COLOR_MAKEFILE ON)
-
-diff --git a/vendor/gtest/CMakeLists.txt b/vendor/gtest/CMakeLists.txt
-index db292946a5..e41e59761e 100644
---- a/vendor/gtest/CMakeLists.txt
-+++ b/vendor/gtest/CMakeLists.txt
-@@ -53,7 +53,7 @@ else()
- cmake_policy(SET CMP0048 NEW)
- project(gtest VERSION ${GOOGLETEST_VERSION} LANGUAGES CXX C)
- endif()
--cmake_minimum_required(VERSION 2.6.4)
-+cmake_minimum_required(VERSION 3.5)
-
- if (POLICY CMP0063) # Visibility
- cmake_policy(SET CMP0063 NEW)