summaryrefslogtreecommitdiff
path: root/sci-libs/p4est/files/p4est-2.8-fix_build_system.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/p4est/files/p4est-2.8-fix_build_system.patch')
-rw-r--r--sci-libs/p4est/files/p4est-2.8-fix_build_system.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/p4est/files/p4est-2.8-fix_build_system.patch b/sci-libs/p4est/files/p4est-2.8-fix_build_system.patch
new file mode 100644
index 000000000000..e1f86165d5f9
--- /dev/null
+++ b/sci-libs/p4est/files/p4est-2.8-fix_build_system.patch
@@ -0,0 +1,24 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3226f2e..8bc5074 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -8,6 +8,8 @@ HOMEPAGE_URL https://www.p4est.org/
+ DESCRIPTION "p4est manages a collection---a forest---of octrees in parallel."
+ VERSION ${PROJECT_VERSION})
+
++set(CMAKE_POSITION_INDEPENDENT_CODE ON)
++
+ include(CTest)
+
+ list(APPEND CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake/Modules)
+@@ -76,8 +78,8 @@ install(DIRECTORY ${PROJECT_SOURCE_DIR}/src/ ${PROJECT_BINARY_DIR}/include/
+
+ install(TARGETS p4est
+ EXPORT ${PROJECT_NAME}Targets
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib)
++ ARCHIVE DESTINATION ${library_reldir}
++ LIBRARY DESTINATION ${library_reldir})
+
+ #--- p8est
+