summaryrefslogtreecommitdiff
path: root/sci-libs/onnx
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/onnx')
-rw-r--r--sci-libs/onnx/Manifest4
-rw-r--r--sci-libs/onnx/metadata.xml3
-rw-r--r--sci-libs/onnx/onnx-1.16.0.ebuild3
3 files changed, 8 insertions, 2 deletions
diff --git a/sci-libs/onnx/Manifest b/sci-libs/onnx/Manifest
index 593b5574ce95..8983eee5da5d 100644
--- a/sci-libs/onnx/Manifest
+++ b/sci-libs/onnx/Manifest
@@ -6,5 +6,5 @@ DIST onnx-1.15.0.tar.gz 12360484 BLAKE2B 4d35b82c128a69124b9bfcb3e56b3d584b7451a
DIST onnx-1.16.0.tar.gz 12428161 BLAKE2B b0d16212c527078fcbe46af8efaf8bfccb0a22825cfee3c88728314599bc90f5b43ae407cc9ec10300ed19367dff769a5d6ba29d2faa61fd8e27029e2d64e83a SHA512 ef641447d8d6c4ed9f083793fe14a8568d6aa7b9b7e7b859a4082e9b892acd801230da2027d097ceaa0d68bbd37b2422b89bb7d1d55d5c3b5955c0f9c7c657c5
EBUILD onnx-1.14.1-r2.ebuild 1287 BLAKE2B 981384a06007a6e1d0bbe602a6ab46cf856a5f6c07223599fbebfd23f2dfef4ded766367580b11e635421b0fb94ca0574fde853ee6dadb4d5f50e978a1eec1b9 SHA512 98cd76cee92bebe93192cce202fd7caf4cbb42d0afcf312acbdcb57992ccc1a7efe1f9cc3d1dc9df9cdc657b5c1ae4bfb2d6e5f86624f4bb6b5853d6a19ec952
EBUILD onnx-1.15.0-r3.ebuild 1281 BLAKE2B 05efb8be8849ab0563b15febc148e04e44e3a350d299e2bee75efc84ccb3538811db1eb4c23102ba72fbfafcdd1148733546fc4dfff49b49f9c2421df3d07aa4 SHA512 6ee2ae88935b7b583490b29c7a58239751aab008e6b928803de259691e66c73b903b39ccda0ade1187eb8fd53bb5ad1facbcc576992cefdf1e54ec9e957f4021
-EBUILD onnx-1.16.0.ebuild 1290 BLAKE2B b8d5a45eed3a10fe5f360939a1998a27d11feef8486088d174918170c220bd7ab3090793f8fb1ed1f36b2c3a4c54c2d66845ba8bf8842802d052132ef7060e75 SHA512 23dbe97165ff9bea6898c3fec881620ee116490bd5ad8dbe7255f5ca038a1dcb7317d8b1e56dcf4c3c9dfb6b141fdbd16c3dc0426c48306d6c9d6d6fe003beb3
-MISC metadata.xml 322 BLAKE2B a78b6feffba2cf354154448a0e0cef5e866ec51ff0158939e7a5be1f3c4cb9bb3b29ae88ae06540627946fc3e0f6e9a63ef4d8951385e840a7a87ada99e1d50a SHA512 9d81e8e43822232c8c8cf690b6bdb9939f04adeb9230f8225a5b0b10083f9555304768901c46cc5d29c41038397bbb3b12e0111c3d0443f4c0003e99b99fc50f
+EBUILD onnx-1.16.0.ebuild 1452 BLAKE2B a3192ee85e6f19a2edaea652a3c286c5861b9610c874e0ed4f4c0d73e7754ef64e34201058b33e9517fc67db3204a9b9f2fbf59892aed44df5b1ee51b05184f5 SHA512 bb415dc0b8926a1388ebf0033af8d3f3a7ea56c004606e8754c3a237b2abcbbb84c2e406966e268c82dd849dbc568e3b5c9e9d50886f5c08b2b31cdd5127d2b4
+MISC metadata.xml 404 BLAKE2B 363f1790f0dd2eace0368d7eb1875c166ba6dd0b2514232050f2f1813ccba854b4f8e58e22a329792126188f06d21bf87436c1dcc10d68b018f7abc8eb8ec3e9 SHA512 6a80de77d763a261cafee9cd69337de5282fa39772a1d2a82c3d954d29221596036346339926a124f9df9b261050d17b58d004cdd01ff2f57347379e9df2e45f
diff --git a/sci-libs/onnx/metadata.xml b/sci-libs/onnx/metadata.xml
index 2a58de7a87a9..e06b5c6e88c2 100644
--- a/sci-libs/onnx/metadata.xml
+++ b/sci-libs/onnx/metadata.xml
@@ -5,6 +5,9 @@
<email>tupone@gentoo.org</email>
<name>Tupone Alfredo</name>
</maintainer>
+ <use>
+ <flag name="disableStaticReg">Disable Static Registration</flag>
+ </use>
<upstream>
<remote-id type="github">onnx/onnx</remote-id>
</upstream>
diff --git a/sci-libs/onnx/onnx-1.16.0.ebuild b/sci-libs/onnx/onnx-1.16.0.ebuild
index e5a6b1c71b41..498d770d736d 100644
--- a/sci-libs/onnx/onnx-1.16.0.ebuild
+++ b/sci-libs/onnx/onnx-1.16.0.ebuild
@@ -15,6 +15,7 @@ SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
+IUSE="disableStaticReg"
RESTRICT="test"
RDEPEND="
@@ -36,6 +37,7 @@ python_configure_all()
-DONNX_USE_PROTOBUF_SHARED_LIBS=ON
-DONNX_USE_LITE_PROTO=ON
-DONNX_BUILD_SHARED_LIBS=ON
+ -DONNX_DISABLE_STATIC_REGISTRATION=$(usex disableStaticReg ON OFF)
)
cmake_src_configure
}
@@ -49,6 +51,7 @@ src_compile() {
-DONNX_USE_PROTOBUF_SHARED_LIBS=ON
-DONNX_USE_LITE_PROTO=ON
-DONNX_BUILD_SHARED_LIBS=ON
+ -DONNX_DISABLE_STATIC_REGISTRATION=$(usex disableStaticReg ON OFF)
)
CMAKE_ARGS="${mycmakeargs[@]}" distutils-r1_src_compile
}