summaryrefslogtreecommitdiff
path: root/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild')
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild
index a628593681d9..1a1079b72566 100644
--- a/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.3.1-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit libtool
+
MYP=${PN}4-${PV}
DESCRIPTION="C++ library for netCDF"
HOMEPAGE="https://www.unidata.ucar.edu/software/netcdf/"
@@ -24,6 +26,11 @@ PATCHES=(
"${FILESDIR}"/${P}-slibtool.patch
)
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_install() {
default
use examples && dodoc -r examples