summaryrefslogtreecommitdiff
path: root/sci-libs/neartree/files/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/neartree/files/CMakeLists.txt')
-rw-r--r--sci-libs/neartree/files/CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-libs/neartree/files/CMakeLists.txt b/sci-libs/neartree/files/CMakeLists.txt
index cb4375da7964..59b64f8c2f8d 100644
--- a/sci-libs/neartree/files/CMakeLists.txt
+++ b/sci-libs/neartree/files/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 2.8)
+cmake_minimum_required(VERSION 2.8.12)
project (Neartree C)
SET (LIB_MAJOR 5)
@@ -7,6 +7,8 @@ SET (LIB_RELEASE 0)
SET (_soversion ${LIB_MAJOR}.${LIB_MINOR}.${LIB_RELEASE})
+include(GNUInstallDirs)
+
include_directories ("${PROJECT_SOURCE_DIR}")
add_library(CNearTree SHARED CNearTree.c)
@@ -14,8 +16,8 @@ target_link_libraries(CNearTree CVector m)
set_target_properties(CNearTree PROPERTIES SOVERSION ${LIB_MAJOR} VERSION ${_soversion})
-INSTALL(TARGETS CNearTree DESTINATION ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+INSTALL(TARGETS CNearTree DESTINATION ${CMAKE_INSTALL_LIBDIR})
install(FILES CNearTree.h rhrand.h TNear.h triple.h
- DESTINATION ${CMAKE_INSTALL_PREFIX}/include)
-install(FILES README_NearTree.txt DESTINATION ${DOC_DIR})
-install(FILES README_NearTree.html index.html DESTINATION ${DOC_DIR}/html)
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+install(FILES README_NearTree.txt DESTINATION ${CMAKE_INSTALL_DOCDIR})
+install(FILES README_NearTree.html index.html DESTINATION ${CMAKE_INSTALL_DOCDIR}/html)