summaryrefslogtreecommitdiff
path: root/sci-libs/linux-gpib
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/linux-gpib')
-rw-r--r--sci-libs/linux-gpib/Manifest2
-rw-r--r--sci-libs/linux-gpib/linux-gpib-4.3.5.ebuild181
2 files changed, 183 insertions, 0 deletions
diff --git a/sci-libs/linux-gpib/Manifest b/sci-libs/linux-gpib/Manifest
index 3550ae768ac7..747f6fb07885 100644
--- a/sci-libs/linux-gpib/Manifest
+++ b/sci-libs/linux-gpib/Manifest
@@ -1,5 +1,7 @@
AUX linux-gpib-4.3.0-perl.patch 546 BLAKE2B 9695c1a9f48a2a8bcb5f5998c40eb909e6b1b3624defe87a08bc4b91b34f53e8176531678dff3d4810b0b85b811eb477795c0dffe0275b864c0e4d4bac9b0ea9 SHA512 21bf64366d4b68dcfc2f4fa932480f8ff6af62bf792fe90c0dd0330606c3b95c073040dfa87bd1e277391a02ad324612d58b6d618d83c637b3df60c638289d06
DIST gpib_firmware-2008-08-10.tar.gz 173004 BLAKE2B 05fcde09de5246b86004c263c733d64316511bdb0b84dfbd9b94cb78e2909c0d191ff21ee0d77e7f0947e9231bd4cd62d6348e8f9beefd6d201b473732ff23d2 SHA512 f2a0ee3316b75ac36ed88568e45ca4c69935a6d10783c65582003ab39686f2a69d3002901866065f4f5efa9fdd4c779e038d1d7ce24bba266a619c164d5ac10d
DIST linux-gpib-4.3.4.tar.gz 1395770 BLAKE2B 3c7182ac127851ebf0f5416ea639d7f858c160ba00f01aa7f7e423f6fb7b3be5b089424d3a473497562d040c194483ebc93d8a2a0f64582fb8907b42e2c4b832 SHA512 397ad86883bf562b004673ae47218108d392f2a15121c95926ea38764e7a76b382cb199fd48c35c9777f34c8eb99965e3d4ea2028e86ce02bcda4bd23127cbd5
+DIST linux-gpib-4.3.5.tar.gz 1462624 BLAKE2B fff30ed1a7abc18cd4317e8f8979ef4014a532baab8c014f9a2eaa3338a2e8e8b672214d3f2b3f44066be15f432861a3fe3d67652f6966e73e561d99ff1e1566 SHA512 018cc255922a6335f8d28418b0a0808c3a369506470d9c81432ac7183ae255217d938a419e10ba2b0c44205a9d901405ce00ad5bdd968db2721cedd83baa2f76
EBUILD linux-gpib-4.3.4-r1.ebuild 4984 BLAKE2B 6763fe0259a9281776564f82013bb7a27351d8fd68399396e4b9d8096c9aae4e3137ae86cccbf984bc5a03618f6fc0de8f4a9992baa03c6d08a5c2271189e057 SHA512 7d1af7aff13e9aa3b47ead8aca9af0aedad31f1eda985f7fbafb8e19f4cb29199bd65aa3e3a1120cfe9cc015936371dc3d93ba681605744c48e431e66c40133f
+EBUILD linux-gpib-4.3.5.ebuild 4985 BLAKE2B 7a6509bcae552683696d0e6cf31e5f03f547038bfaf215809a4f67550ad06c5fcd1e2fe37df689e7c9320c95f222cb873ff0b32cbfc85150a020fe514e5f01b5 SHA512 fbb969ef412db9656ec279d87749bea111280d000e7a2f4a5721fa08e13f7b1d8b4d91ac1412090b8260a5d0f2a40b6942eed6b5ad328b2e0ca4ab9ddc6ed5b7
MISC metadata.xml 548 BLAKE2B c976143b910efb6a8920f064f35fdac9cb325ff272aca8a7644511300f4dfe9232c280577a90eae225ca4f88bc2b4cd09d175d4190bc13513d89457f57c9bb52 SHA512 c611a420ab28d623b5b9167bd59c04c2fe27404a7fd85de72a555f99ef8bad4383702482ae808d4eb66014a9e63ca057aa7195748f9c230f0778fcbde07fb71f
diff --git a/sci-libs/linux-gpib/linux-gpib-4.3.5.ebuild b/sci-libs/linux-gpib/linux-gpib-4.3.5.ebuild
new file mode 100644
index 000000000000..0584a67f9064
--- /dev/null
+++ b/sci-libs/linux-gpib/linux-gpib-4.3.5.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit readme.gentoo-r1 autotools perl-functions python-single-r1 udev
+
+# Check for latest firmware version on bump
+FW_PV="2008-08-10"
+
+DESCRIPTION="Driver library for GPIB (IEEE 488.2) hardware"
+HOMEPAGE="https://linux-gpib.sourceforge.io/"
+SRC_URI="mirror://sourceforge/linux-gpib/${P}.tar.gz
+ firmware? ( https://linux-gpib.sourceforge.io/firmware/gpib_firmware-${FW_PV}.tar.gz )
+"
+S="${WORKDIR}/${PN}-user-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="pcmcia static guile perl php python tcl doc firmware"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMONDEPEND="
+ sys-libs/readline:=
+ tcl? ( dev-lang/tcl:0= )
+ guile? ( dev-scheme/guile:12 )
+ perl? ( dev-lang/perl:= )
+ php? ( dev-lang/php:= )
+ python? ( ${PYTHON_DEPS} )
+ firmware? ( sys-apps/fxload )
+"
+RDEPEND="${COMMONDEPEND}
+ acct-group/gpib
+ ~sci-libs/linux-gpib-modules-${PV}
+"
+DEPEND="${COMMONDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )
+ perl? ( virtual/perl-ExtUtils-MakeMaker )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-perl.patch
+)
+
+pkg_setup() {
+ use perl && perl_set_version
+ use python && python_setup
+}
+
+src_unpack() {
+ default
+ unpack "${WORKDIR}/${P}/${PN}-user-${PV}.tar.gz"
+}
+
+src_prepare() {
+ default
+
+ # We have to use --root instead of --prefix for setup.py.
+ # Otherwise the python files are not installed properly into site-packages.
+ sed -i -e \
+ 's/--prefix=$(DESTDIR)$(prefix)/--root=$(DESTDIR)/g' \
+ language/python/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static) \
+ $(use_enable guile guile-binding) \
+ $(use_enable perl perl-binding) \
+ $(use_enable php php-binding) \
+ $(use_enable python python-binding) \
+ $(use_enable tcl tcl-binding) \
+ $(use_enable doc documentation)
+}
+
+src_install() {
+ # PYTHONDONTWRITEBYTECODE=0 is required, otherwise
+ # installation of the python files is skipped
+ FIRM_DIR=/usr/share/usb
+ emake \
+ DESTDIR="${ED}" \
+ INSTALL_MOD_PATH="${ED}" \
+ HOTPLUG_USB_CONF_DIR=/etc/hotplug/usb \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ USB_FIRMWARE_DIR=${FIRM_DIR} \
+ PYTHONDONTWRITEBYTECODE=0 \
+ docdir="/usr/share/doc/${PF}/html" install
+
+ if use perl; then
+ einfo "Installing perl module"
+ cd "${S}"/language/perl || die
+ emake DESTDIR="${ED}" install
+ perl_fix_packlist
+ perl_delete_emptybsdir
+ cd "${S}" || die
+ fi
+
+ echo "KERNEL==\"gpib[0-9]*\", MODE=\"0660\", GROUP=\"gpib\"" >> 99-gpib.rules
+ udev_dorules 99-gpib.rules
+
+ dodoc doc/linux-gpib.pdf ChangeLog AUTHORS README* NEWS
+
+ insinto /etc
+ newins util/templates/gpib.conf gpib.conf
+ newins util/templates/gpib.conf gpib.conf.example
+
+ if use pcmcia; then
+ insinto /etc/pcmcia
+ doins "${S}"/etc/pcmcia/*
+ fi
+
+ # fix rules files
+ local f
+ find "${ED}$(get_udevdir)"/rules.d -type f -print0 | while read -rd '' f ; do
+ grep -q "${ED}" "${f}" && einfo "File ${f} contains a temporary path, fixing."
+ sed -i -e "s:${ED}:/:g" "${f}"
+ done
+
+ DOC_CONTENTS="
+As the udev rules were changed and refactored in this release it is
+necessary to remove any manually installed pre-4.3.0 gpib udev rules files
+in /etc/udev/rules.d/. The files to remove are:
+\n
+ 99-agilent_82357a.rules\n
+ 99-gpib-generic.rules\n
+ 99-ni_usb_gpib.rules\n
+\n
+You need to run the 'gpib_config' utility to setup the driver before
+you can use it. In order to do it automatically you can add to your
+start script something like this (supposing the appropriate driver
+is loaded on the startup):
+\n
+ gpib_config --minor 0
+\n
+To give a user access to the computer's gpib board you will have to add
+them to the group 'gpib' or, you could change the permissions on the device
+files /dev/gpib[0-15] to something you like better, using 'chmod'
+\n
+Edit /etc/gpib.conf to match your interface board, and any devices you wish
+to open via ibfind(). See the documentation in /usr/share/linux-gpib/html for
+more information.
+\n
+"
+
+ if use pcmcia; then
+ DOC_CONTENTS+='
+For PCMCIA cards:\n
+All files needed for a PCMCIA board were copied to /etc/pcmcia.
+You may wish to edit the options passed to the gpib_config call in the
+/etc/pcmcia/linux-gpib-pcmcia script.
+You may need to send a SIGHUP signal to the cardmgr daemon to force it
+to reload the files in /etc/pcmcia \(alternatively you could use your
+pcmcia init.d script to restart the cardmgr, or you could just reboot\).
+The driver module will be loaded as needed by the cardmgr.
+
+'
+ fi
+
+ if use firmware; then
+ DOC_CONTENTS+='
+For Agilent \(HP\) 82341C and 82341D cards:
+The firmware for these boards is uploaded by passing the appropriate
+firmware file from /usr/share/linux-gpib/hp_82341 directory to
+gpib_config using the -I or --init-data command line option. Example:\n
+gpib_config --minor 0 --init-data /usr/share/linux-gpib/hp_82341/hp_82341c_fw.bin
+'
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}