summaryrefslogtreecommitdiff
path: root/sci-libs/libcifpp/libcifpp-2.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libcifpp/libcifpp-2.0.4.ebuild')
-rw-r--r--sci-libs/libcifpp/libcifpp-2.0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/libcifpp/libcifpp-2.0.4.ebuild b/sci-libs/libcifpp/libcifpp-2.0.4.ebuild
new file mode 100644
index 000000000000..1cbb3962edf8
--- /dev/null
+++ b/sci-libs/libcifpp/libcifpp-2.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="Code to work with mmCIF and PDB files"
+HOMEPAGE="https://github.com/PDB-REDO/libcifpp"
+SRC_URI="
+ https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ ftp://ftp.wwpdb.org/pub/pdb/data/monomers/components.cif.gz -> components-${PV}.cif.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=dev-libs/boost-1.70.0:0=[threads(+)]
+"
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ cp "${WORKDIR}"/components-${PV}.cif data/components.cif || die
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DCIFPP_BUILD_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}