summaryrefslogtreecommitdiff
path: root/sci-libs/lapack
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lapack')
-rw-r--r--sci-libs/lapack/Manifest3
-rw-r--r--sci-libs/lapack/lapack-3.8.0.ebuild92
-rw-r--r--sci-libs/lapack/metadata.xml30
3 files changed, 125 insertions, 0 deletions
diff --git a/sci-libs/lapack/Manifest b/sci-libs/lapack/Manifest
new file mode 100644
index 000000000000..a1ad30c5c624
--- /dev/null
+++ b/sci-libs/lapack/Manifest
@@ -0,0 +1,3 @@
+DIST lapack-3.8.0.tar.gz 7426094 BLAKE2B 27cd75eea498250382b2df6f5d7dc95fdee8d37b1a0faba5296ca0145ec40a1165a4ecc727aa1647086be6783b50cf475f79cea0f30f541da789051db99b2f37 SHA512 17786cb7306fccdc9b4a242de7f64fc261ebe6a10b6ec55f519deb4cb673cb137e8742aa5698fd2dc52f1cd56d3bd116af3f593a01dcf6770c4dcc86c50b2a7f
+EBUILD lapack-3.8.0.ebuild 3034 BLAKE2B 80cc6eb969420eba0ce80cffbbb6297b302c13f4b8a3dfb84ae141277937d79aab97069489f0ff74f10167c84d7d42093eabf58e17d3406190b17a3e8bda86f7 SHA512 27672b9e60c7448ab86ea403db2b3f65996e97df09fedb47e81c9443d939b589d3d83a61dba8fe37f53dd0cc07af54f0b95fa5446ecdedd1f27195667902941e
+MISC metadata.xml 1423 BLAKE2B 2ec6d7c07c4827cca666cddb7e7b2e47238ff3fd40fd5e15463196812a7a82e0b85e5d36ae2a2c3315c3b4e0b5f3d4a79a953cb1703836b20dc14862956bcf29 SHA512 39a5e8738999caaf00b4f7fcdb3afdd1405a7c817920b9247a76dbc64e06f8c2011763031a058673ac8a411cad2219cbd7c8664d379535e2afea72d2bd578fbe
diff --git a/sci-libs/lapack/lapack-3.8.0.ebuild b/sci-libs/lapack/lapack-3.8.0.ebuild
new file mode 100644
index 000000000000..3fb7fa9984db
--- /dev/null
+++ b/sci-libs/lapack/lapack-3.8.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CMAKE_MAKEFILE_GENERATOR=emake
+inherit cmake-utils
+
+DESCRIPTION="BLAS,CBLAS,LAPACK,LAPACKE reference implementations"
+HOMEPAGE="http://www.netlib.org/lapack/"
+SRC_URI="http://www.netlib.org/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="lapacke doc eselect-ldso"
+# TODO: static-libs 64bit-index
+
+RDEPEND="
+ eselect-ldso? ( >=app-eselect/eselect-blas-0.2
+ >=app-eselect/eselect-lapack-0.2 )
+ !app-eselect/eselect-cblas
+ !sci-libs/blas-reference
+ !sci-libs/cblas-reference
+ !sci-libs/lapack-reference
+ !sci-libs/lapacke-reference
+ virtual/fortran
+ doc? ( app-doc/blas-docs )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCBLAS=ON
+ -DLAPACKE=$(usex lapacke)
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install () {
+ cmake-utils_src_install
+
+ use eselect-ldso || return
+ # Create private lib directory for eselect::blas (ld.so.conf)
+ dodir /usr/$(get_libdir)/blas/reference
+ dosym ../../libblas.so usr/$(get_libdir)/blas/reference/libblas.so
+ dosym ../../libblas.so.3 usr/$(get_libdir)/blas/reference/libblas.so.3
+ dosym ../../libcblas.so usr/$(get_libdir)/blas/reference/libcblas.so
+ dosym ../../libcblas.so.3 usr/$(get_libdir)/blas/reference/libcblas.so.3
+
+ # Create private lib directory for eselect::lapack (ld.so.conf)
+ dodir /usr/$(get_libdir)/lapack/reference
+ dosym ../../liblapack.so usr/$(get_libdir)/lapack/reference/liblapack.so
+ dosym ../../liblapack.so.3 usr/$(get_libdir)/lapack/reference/liblapack.so.3
+}
+
+pkg_postinst () {
+ use eselect-ldso || return
+
+ local me=reference libdir=$(get_libdir)
+ # check eselect-blas
+ eselect blas add ${libdir} "${EROOT}"/usr/${libdir}/blas/${me} ${me}
+ local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
+ if [[ ${current_blas} == ${me} || -z ${current_blas} ]]; then
+ eselect blas set ${libdir} ${me}
+ elog "Current eselect: BLAS ($libdir) -> [${current_blas}]."
+ else
+ elog "Current eselect: BLAS ($libdir) -> [${current_blas}]."
+ elog "To use blas [${me}] implementation, you have to issue (as root):"
+ elog "\t eselect blas set ${libdir} ${me}"
+ fi
+
+ # check eselect-lapack
+ eselect lapack add ${libdir} "${EROOT}"/usr/${libdir}/lapack/${me} ${me}
+ local current_lapack=$(eselect lapack show ${libdir} | cut -d' ' -f2)
+ if [[ ${current_lapack} == ${me} || -z ${current_lapack} ]]; then
+ eselect lapack set ${libdir} ${me}
+ elog "Current eselect: LAPACK ($libdir) -> [${current_lapack}]."
+ else
+ elog "Current eselect: LAPACK ($libdir) -> [${current_lapack}]."
+ elog "To use lapack [${me}] implementation, you have to issue (as root):"
+ elog "\t eselect lapack set ${libdir} ${me}"
+ fi
+}
+
+pkg_postrm () {
+ use eselect-ldso || return
+
+ eselect blas validate
+ eselect lapack validate
+}
diff --git a/sci-libs/lapack/metadata.xml b/sci-libs/lapack/metadata.xml
new file mode 100644
index 000000000000..adc276993c4f
--- /dev/null
+++ b/sci-libs/lapack/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+The BLAS (Basic Linear Algebra Subprograms) are high quality "building
+block" routines for performing basic vector and matrix operations. Level 1
+BLAS do vector-vector operations, Level 2 BLAS do matrix-vector operations,
+and Level 3 BLAS do matrix-matrix operations. Because the BLAS are
+efficient, portable, and widely available, they're commonly used in the
+development of high quality linear algebra software, LAPACK for
+example. This packages implements the reference FORTRAN 77 library,
+the reference C library as a wrapper to the FORTRAN 77 BLAS library.
+
+LAPACK is a comprehensive library that does linear algebra
+operations including matrix inversions, least squared solutions to
+linear sets of equations, eigenvector analysis, singular value
+decomposition, etc. It is a very comprehensive and reputable package
+that has found extensive use in the scientific community.
+This package installs the reference FORTRAN 77 implementation from Netlib.
+ </longdescription>
+ <use>
+ <flag name="lapacke">Build LAPACKE</flag>
+ <flag name="eselect-ldso">Enable runtime library switching by
+ eselect and ld.so.</flag>
+ </use>
+</pkgmetadata>