summaryrefslogtreecommitdiff
path: root/sci-libs/ipp
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ipp')
-rw-r--r--sci-libs/ipp/Manifest5
-rw-r--r--sci-libs/ipp/ipp-8.2.2.187.ebuild28
-rw-r--r--sci-libs/ipp/ipp-8.2.3.233.ebuild28
-rw-r--r--sci-libs/ipp/metadata.xml13
4 files changed, 74 insertions, 0 deletions
diff --git a/sci-libs/ipp/Manifest b/sci-libs/ipp/Manifest
new file mode 100644
index 000000000000..505cb48a22d3
--- /dev/null
+++ b/sci-libs/ipp/Manifest
@@ -0,0 +1,5 @@
+DIST parallel_studio_xe_2015_update3.tgz 4156836825 BLAKE2B afa2e9d776b721605508cd2cb659f112fa1bab728a94d548d1c75eeb3db764ac82d591dcf2fe505cf2ef107a51fca8eafa6f7e8d7ce12243c5c45e44c674ae8a SHA512 eccc2bfe85ccd039a2ec9e334d370e49d43baa0522d095c087a5982aa08bddb4c97bfc3125bd09f5cd57d3ed252c598012e1f2670b8373a1b3bb455825d18f96
+DIST parallel_studio_xe_2015_update6.tgz 4190044333 BLAKE2B b038cda914b4c736259b84d2958a16a718fc75fe1663b4a835f4011fadb553a28f5c231d6f0a2744fc3eec257b390b021b0af709d69a5d10845cf9d63d1aa320 SHA512 a9896289db8e820f02c330702ff1e954af11af5f9bbc0e5623a001b3a8c33a2bcb8660ac8b0e569994a3682bfd263bf119dbe6a43fb343139adbeaaaa13f8a81
+EBUILD ipp-8.2.2.187.ebuild 715 BLAKE2B 0b65f922d644e6277160880b2301a71e7fb0e2d5129e87b88783c5baa248f5504ce9ead0ea16495c2d03d5efa95b90c16e087190029182431a28471c247f9b4b SHA512 25521f78842c613c20c10e43d8f8c66b790bd974f6009bc34cb4f834f2eb80c650e989372ed59ddac7a4ea4696516d398f371430513e7f6d82baf04efb52051f
+EBUILD ipp-8.2.3.233.ebuild 715 BLAKE2B 2c322a8075e3b615777190dae16d3165e2614b29b90fca80d3f7a35f8cb71dc24652146df2604a4d2323daa0e27ebe1466ed15f2c5b3affd047e33e251bcbe8e SHA512 d5aff5dc0971ba6421ae25ef2fc0ced4f43482b44c3ecf30baaf9ff4af8d0090ed712e2de369d6c6481159310f88faa6b1b29b0852af9db3e98b4c621b3ceb56
+MISC metadata.xml 500 BLAKE2B 0e8630c46aac418e4cb37ff792c4f722254504ba15bb1880efc85e7e82bacaea2b435295177997a7341dd586bd3bd3dc2fb5e6d2bc9f678622e9de612d97baaf SHA512 c6a74517c3ee5a5f7495353d057c2f6ffbdb22c9a26a12893473f23c78238b771802f0f963aa1bc2250115925e23b15a3ca12ac1d0df895ebb5f2659d1057237
diff --git a/sci-libs/ipp/ipp-8.2.2.187.ebuild b/sci-libs/ipp/ipp-8.2.2.187.ebuild
new file mode 100644
index 000000000000..c9ce9ca2f3ae
--- /dev/null
+++ b/sci-libs/ipp/ipp-8.2.2.187.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=7538
+INTEL_DPV=2015_update3
+INTEL_SUBDIR=composerxe
+INTEL_SINGLE_ARCH=false
+
+inherit intel-sdp
+
+DESCRIPTION="Intel Integrated Performance Primitives for multimedia and data processing"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-ipp/"
+
+IUSE=""
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-libs/intel-common-15"
+DEPEND=""
+
+CHECKREQS_DISK_BUILD=6400M
+
+INTEL_BIN_RPMS=( ipp-{ac,di,gen,jp,mt,mt-devel,mx,rr,sc,st,st-devel,vc} )
+INTEL_DAT_RPMS=( ipp-common ipp-{ac,di,gen,jp,mx,rr,sc,st-devel,vc}-common )
+
+INTEL_SKIP_LICENSE=true
diff --git a/sci-libs/ipp/ipp-8.2.3.233.ebuild b/sci-libs/ipp/ipp-8.2.3.233.ebuild
new file mode 100644
index 000000000000..14d562a8dc99
--- /dev/null
+++ b/sci-libs/ipp/ipp-8.2.3.233.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=8470
+INTEL_DPV=2015_update6
+INTEL_SUBDIR=composerxe
+INTEL_SINGLE_ARCH=false
+
+inherit intel-sdp
+
+DESCRIPTION="Intel Integrated Performance Primitives for multimedia and data processing"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-ipp/"
+
+IUSE=""
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-libs/intel-common-15"
+DEPEND=""
+
+CHECKREQS_DISK_BUILD=6400M
+
+INTEL_BIN_RPMS=( ipp-{ac,di,gen,jp,mt,mt-devel,mx,rr,sc,st,st-devel,vc} )
+INTEL_DAT_RPMS=( ipp-common ipp-{ac,di,gen,jp,mx,rr,sc,st-devel,vc}-common )
+
+INTEL_SKIP_LICENSE=true
diff --git a/sci-libs/ipp/metadata.xml b/sci-libs/ipp/metadata.xml
new file mode 100644
index 000000000000..b61694fd8092
--- /dev/null
+++ b/sci-libs/ipp/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Intel(R) Integrated Performance Primitives (Intel(R) IPP) is a
+ library of multi-core-ready, optimized software functions for
+ multimedia data processing, and communications applications.
+</longdescription>
+</pkgmetadata>