summaryrefslogtreecommitdiff
path: root/sci-libs/indilib/files/indilib-2.0.7-fix-system-httplib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/indilib/files/indilib-2.0.7-fix-system-httplib.patch')
-rw-r--r--sci-libs/indilib/files/indilib-2.0.7-fix-system-httplib.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/indilib/files/indilib-2.0.7-fix-system-httplib.patch b/sci-libs/indilib/files/indilib-2.0.7-fix-system-httplib.patch
new file mode 100644
index 000000000000..81876a468fa2
--- /dev/null
+++ b/sci-libs/indilib/files/indilib-2.0.7-fix-system-httplib.patch
@@ -0,0 +1,32 @@
+From 1d9e7a4645aa9d1c8534a0e69c3fb212382ac1ed Mon Sep 17 00:00:00 2001
+From: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Fri, 12 Apr 2024 11:31:01 +0200
+Subject: [PATCH] Link against httplib if using system libraries (#2039)
+
+---
+ drivers/auxiliary/CMakeLists.txt | 2 +-
+ drivers/dome/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/drivers/auxiliary/CMakeLists.txt b/drivers/auxiliary/CMakeLists.txt
+index 66f7e3a615..41279d0a9d 100644
+--- a/drivers/auxiliary/CMakeLists.txt
++++ b/drivers/auxiliary/CMakeLists.txt
+@@ -313,5 +313,5 @@ SET(dragonlight_SRC
+ dragonlight.cpp)
+
+ add_executable(indi_dragon_light ${dragonlight_SRC})
+-target_link_libraries(indi_dragon_light indidriver)
++target_link_libraries(indi_dragon_light indidriver ${HTTPLIB_LIBRARY})
+ install(TARGETS indi_dragon_light RUNTIME DESTINATION bin)
+diff --git a/drivers/dome/CMakeLists.txt b/drivers/dome/CMakeLists.txt
+index 9dfdc812b8..377af11d2f 100644
+--- a/drivers/dome/CMakeLists.txt
++++ b/drivers/dome/CMakeLists.txt
+@@ -80,5 +80,5 @@ SET(dragonlair_SRC
+ dragonlair.cpp)
+
+ add_executable(indi_dragonlair_dome ${dragonlair_SRC})
+-target_link_libraries(indi_dragonlair_dome indidriver)
++target_link_libraries(indi_dragonlair_dome indidriver ${HTTPLIB_LIBRARY})
+ install(TARGETS indi_dragonlair_dome RUNTIME DESTINATION bin)