summaryrefslogtreecommitdiff
path: root/sci-libs/ignition-math/ignition-math-6.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ignition-math/ignition-math-6.8.0.ebuild')
-rw-r--r--sci-libs/ignition-math/ignition-math-6.8.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/ignition-math/ignition-math-6.8.0.ebuild b/sci-libs/ignition-math/ignition-math-6.8.0.ebuild
new file mode 100644
index 000000000000..fc7acfaa88c1
--- /dev/null
+++ b/sci-libs/ignition-math/ignition-math-6.8.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+inherit cmake vcs-snapshot
+
+DESCRIPTION="A small, fast, and high performance math library for robot applications"
+HOMEPAGE="https://github.com/ignitionrobotics/ign-math"
+SRC_URI="https://github.com/ignitionrobotics/ign-math/archive/${PN}6_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="6/6"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3
+ dev-util/ignition-cmake:2"
+BDEPEND="
+ dev-util/ignition-cmake:2"
+
+S="${WORKDIR}/${PN}6_${PV}"
+PATCHES=( "${FILESDIR}/includes.patch" )