summaryrefslogtreecommitdiff
path: root/sci-libs/hdf5/hdf5-1.10.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/hdf5/hdf5-1.10.5.ebuild')
-rw-r--r--sci-libs/hdf5/hdf5-1.10.5.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sci-libs/hdf5/hdf5-1.10.5.ebuild b/sci-libs/hdf5/hdf5-1.10.5.ebuild
index a3c248db158e..deaec088dd13 100644
--- a/sci-libs/hdf5/hdf5-1.10.5.ebuild
+++ b/sci-libs/hdf5/hdf5-1.10.5.ebuild
@@ -17,7 +17,7 @@ SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${MAJOR_P}/${MY_P}/src/${MY_P
LICENSE="NCSA-HDF"
SLOT="0/${PV%%_p*}"
KEYWORDS="alpha amd64 ~arm arm64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="cxx debug examples fortran +hl mpi static-libs szip threads zlib"
+IUSE="cxx debug examples fortran +hl mpi szip threads zlib"
REQUIRED_USE="
cxx? ( !mpi ) mpi? ( !cxx )
@@ -79,10 +79,11 @@ src_prepare() {
src_configure() {
econf \
+ --disable-static \
--enable-deprecated-symbols \
- $(use debug && echo --enable-build-mode=debug || echo --enable-build-mode=production) \
- $(use_enable debug codestack) \
+ --enable-build-mode=$(usex debug debug production) \
$(use_enable cxx) \
+ $(use_enable debug codestack) \
$(use_enable fortran) \
$(use_enable hl) \
$(use_enable mpi parallel) \
@@ -91,3 +92,10 @@ src_configure() {
$(use_with threads pthread) \
$(use_with zlib)
}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}