summaryrefslogtreecommitdiff
path: root/sci-libs/gloo
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gloo')
-rw-r--r--sci-libs/gloo/Manifest4
-rw-r--r--sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch64
-rw-r--r--sci-libs/gloo/gloo-2022.05.18.ebuild49
-rw-r--r--sci-libs/gloo/metadata.xml15
4 files changed, 132 insertions, 0 deletions
diff --git a/sci-libs/gloo/Manifest b/sci-libs/gloo/Manifest
new file mode 100644
index 000000000000..967cace160e3
--- /dev/null
+++ b/sci-libs/gloo/Manifest
@@ -0,0 +1,4 @@
+AUX gloo-2022.05.18-gentoo.patch 2285 BLAKE2B fc8ab0b188fa7e1acacf3a915c34842ff73e7dd72762165530d175c71ccb62bf7a43f754821ded74a2b67d626e2c16b1f3df59fd97968b3544ff8020e6f099b0 SHA512 b8b75b0258a89c5105f0b7888b25aa9c5f9aa1c997136f261559cba4b5f4fae8f6e4dcea4e33c2cf7572b3798ad4ec3033fdc46d937d965bacd34cc5f40e9703
+DIST gloo-2022.05.18.tar.gz 251778 BLAKE2B 90bd97cff437d030b87c333ebb6679f199491b97826f09278b7a6740d781ca750af4e8eda18f29a4311462473146aae1fd0686443a0eb2c73e8ba34e6837b0af SHA512 356b4bd4480fda0f9db039babd223c17ed24c35945877bdb6c5b28eb45ee8ce08def73d308bc906c478c4c9d485bb0f74080d90c7a4fafe84818df0a97a7f6e2
+EBUILD gloo-2022.05.18.ebuild 1044 BLAKE2B 3123f3d977677405e28d7a80b7666a781fad05880a6894e56187a92c4167a7d72a9d2a0e488ca379668bc15fe2d9a9bc7551a8d0c001f4f9f9ae7ac55a0274d9 SHA512 022673a9308eecf06f81e17b26f58fd29f8daca24b959e1e4ebc44db6b7a0ed49052104a2da683685a530576c0164fd5dafa288780f9936000aada25b1ccd9b7
+MISC metadata.xml 492 BLAKE2B be64dabc0bd193d99c4458e6bad8c78042ef1d65800ebd3a3818ffdac3b361f18011ae044036e3c73deba03886e8aa6ffdcb5c2a66b635ecc2f29d636c660227 SHA512 e342a7d570f7ff12718f51e91fd6d359d038670dfb3b679a4cd8d7de61bef8d4b048e2362303bb925eddfd7c40e67f4179e89c24dc2f9b5c21e5a220bf9d4aa2
diff --git a/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch b/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch
new file mode 100644
index 000000000000..41a1ace42dc7
--- /dev/null
+++ b/sci-libs/gloo/files/gloo-2022.05.18-gentoo.patch
@@ -0,0 +1,64 @@
+--- a/CMakeLists.txt 2022-06-09 08:29:13.172119535 +0200
++++ b/CMakeLists.txt 2022-06-09 08:29:27.474929097 +0200
+@@ -2,6 +2,9 @@
+
+ project(gloo CXX C)
+
++include(GNUInstallDirs)
++include(CTest)
++
+ set(GLOO_VERSION_MAJOR 0)
+ set(GLOO_VERSION_MINOR 5)
+ set(GLOO_VERSION_PATCH 0)
+--- a/gloo/CMakeLists.txt 2022-06-09 08:41:09.883773600 +0200
++++ b/gloo/CMakeLists.txt 2022-06-09 08:42:39.045637103 +0200
+@@ -176,7 +176,7 @@
+ # want to statically link with Gloo and not install any artifacts.
+ if(GLOO_INSTALL)
+ install(TARGETS gloo EXPORT GlooTargets
+- DESTINATION ${CMAKE_INSTALL_PREFIX}/lib)
++ DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ if(USE_CUDA)
+ install(TARGETS gloo_cuda EXPORT GlooTargets
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib)
+--- a/gloo/test/CMakeLists.txt 2022-06-10 22:17:03.682856314 +0200
++++ b/gloo/test/CMakeLists.txt 2022-06-10 22:17:49.671242697 +0200
+@@ -68,3 +68,4 @@
+ gloo_hip_add_executable(gloo_test_hip ${GLOO_TEST_HIP_SRCS})
+ target_link_libraries(gloo_test_hip gloo_hip gtest OpenSSL::SSL OpenSSL::Crypto)
+ endif()
++add_test(NAME gloo_test COMMAND gloo_test)
+--- a/gloo/test/memory_test.cc 2022-06-10 22:28:53.815371465 +0200
++++ b/gloo/test/memory_test.cc 2022-06-10 22:29:14.504094854 +0200
+@@ -52,7 +52,7 @@
+ class MemoryTest : public BaseTest,
+ public ::testing::WithParamInterface<Param> {};
+
+-TEST_P(MemoryTest, ManySlotsNoLeaks) {
++TEST_P(MemoryTest, DISABLED_ManySlotsNoLeaks) {
+ const auto transport = GetParam();
+ spawn(transport, 2, [&](std::shared_ptr<Context> context) {
+ size_t tmp0;
+--- a/cmake/Dependencies.cmake 2022-06-11 23:38:57.367089917 +0200
++++ b/cmake/Dependencies.cmake 2022-06-11 23:48:57.690866797 +0200
+@@ -81,7 +81,7 @@
+ pkg_search_module(libuv REQUIRED libuv>=1.26)
+ find_file(
+ libuv_LIBRARY
+- NAMES libuv.a libuv_a.a
++ NAMES libuv.so
+ PATHS ${libuv_LIBDIR}
+ NO_DEFAULT_PATH)
+ if(NOT EXISTS ${libuv_LIBRARY})
+@@ -90,10 +90,7 @@
+ endif()
+
+ add_library(uv_a INTERFACE IMPORTED)
+- set_target_properties(uv_a PROPERTIES
+- INTERFACE_INCLUDE_DIRECTORIES ${libuv_INCLUDE_DIRS}
+- INTERFACE_LINK_LIBRARIES ${libuv_LIBRARY}
+- )
++ list(APPEND gloo_DEPENDENCY_LIBS -luv)
+ endif()
+ endif()
+
diff --git a/sci-libs/gloo/gloo-2022.05.18.ebuild b/sci-libs/gloo/gloo-2022.05.18.ebuild
new file mode 100644
index 000000000000..5b1fc445c18d
--- /dev/null
+++ b/sci-libs/gloo/gloo-2022.05.18.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+CommitId=5b143513263133af2b95547e97c07cebeb72bf72
+
+DESCRIPTION="library of floating-point neural network inference operators"
+HOMEPAGE="https://github.com/facebookincubator/gloo/"
+SRC_URI="https://github.com/facebookincubator/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libuv mpi redis ssl test"
+
+RDEPEND="
+ libuv? ( dev-libs/libuv )
+ mpi? ( virtual/mpi )
+ redis? (
+ dev-db/redis
+ dev-libs/hiredis
+ )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}
+"
+
+BDEPEND="test? ( dev-cpp/gtest )"
+RESTRICT="test" # For some test the network is needed
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TEST=$(usex test ON OFF)
+ -DUSE_LIBUV=$(usex libuv ON OFF)
+ -DUSE_MPI=$(usex mpi ON OFF)
+ -DUSE_REDIS=$(usex redis ON OFF)
+ -DUSE_TCP_OPENSSL_LINK=$(usex ssl ON OFF)
+ )
+ cmake_src_configure
+}
diff --git a/sci-libs/gloo/metadata.xml b/sci-libs/gloo/metadata.xml
new file mode 100644
index 000000000000..453b2878b484
--- /dev/null
+++ b/sci-libs/gloo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facebookincubator/gloo</remote-id>
+ </upstream>
+ <use>
+ <flag name="libuv">Enable libuv support</flag>
+ <flag name="redis">Enable Redis backend for storage via <pkg>dev-libs/hiredis</pkg></flag>
+ </use>
+</pkgmetadata>