summaryrefslogtreecommitdiff
path: root/sci-libs/gdal/gdal-2.4.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gdal/gdal-2.4.1-r2.ebuild')
-rw-r--r--sci-libs/gdal/gdal-2.4.1-r2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sci-libs/gdal/gdal-2.4.1-r2.ebuild b/sci-libs/gdal/gdal-2.4.1-r2.ebuild
index fa26cc48e938..ef434fe5b011 100644
--- a/sci-libs/gdal/gdal-2.4.1-r2.ebuild
+++ b/sci-libs/gdal/gdal-2.4.1-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
GENTOO_DEPEND_ON_PERL="no"
-PYTHON_COMPAT=( python3_{5,6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8} )
DISTUTILS_OPTIONAL=1
inherit autotools perl-module distutils-r1 flag-o-matic java-pkg-opt-2 toolchain-funcs
@@ -15,7 +15,7 @@ SRC_URI="https://download.osgeo.org/${PN}/${PV}/${P}.tar.gz"
SLOT="0/2.3"
LICENSE="BSD Info-ZIP MIT"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="armadillo +aux_xml curl debug doc fits geos gif gml hdf5 java jpeg jpeg2k lzma mdb mysql netcdf odbc ogdi opencl oracle pdf perl png postgres python spatialite sqlite threads webp xls zstd"
+IUSE="armadillo +aux-xml curl debug doc fits geos gif gml hdf5 java jpeg jpeg2k lzma mdb mysql netcdf odbc ogdi opencl oracle pdf perl png postgres python spatialite sqlite threads webp xls zstd"
REQUIRED_USE="
mdb? ( java )
@@ -85,6 +85,7 @@ PATCHES=(
"${FILESDIR}/${P}-poppler-0.76.patch"
"${FILESDIR}/${P}-swig-4.patch" # bug 689110
"${FILESDIR}/${P}-poppler-0.82.patch"
+ "${FILESDIR}"/${P}-poppler-0.83-{1,2}.patch # bug 703790
)
src_prepare() {
@@ -186,7 +187,7 @@ src_configure() {
--disable-lto
$(use_enable debug)
$(use_with armadillo)
- $(use_with aux_xml pam)
+ $(use_with aux-xml pam)
$(use_with curl)
$(use_with fits cfitsio)
$(use_with geos)