summaryrefslogtreecommitdiff
path: root/sci-libs/fflas-ffpack/files
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/fflas-ffpack/files')
-rw-r--r--sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-fix-internal-linking.patch70
-rw-r--r--sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-fabi-version.patch31
-rw-r--r--sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-test-echelon.patch39
3 files changed, 140 insertions, 0 deletions
diff --git a/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-fix-internal-linking.patch b/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-fix-internal-linking.patch
new file mode 100644
index 000000000000..5f085554c33f
--- /dev/null
+++ b/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-fix-internal-linking.patch
@@ -0,0 +1,70 @@
+From 7c959a3e938a32b386418ddfdfbb884a96762d90 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sat, 7 Aug 2021 08:14:44 -0400
+Subject: [PATCH 1/1] fflas-ffpack/interfaces/libs/Makefile.am: fix internal
+ linking.
+
+This is just,
+
+ https://github.com/linbox-team/fflas-ffpack/pull/339
+
+but rebased onto the old release tarball.
+---
+ fflas-ffpack/interfaces/libs/Makefile.am | 22 ++++++++--------------
+ 1 file changed, 8 insertions(+), 14 deletions(-)
+
+diff --git a/fflas-ffpack/interfaces/libs/Makefile.am b/fflas-ffpack/interfaces/libs/Makefile.am
+index 8c56746..449f6e4 100644
+--- a/fflas-ffpack/interfaces/libs/Makefile.am
++++ b/fflas-ffpack/interfaces/libs/Makefile.am
+@@ -24,7 +24,6 @@ pkgincludesubdir=$(pkgincludedir)/interfaces/libs
+
+ AM_CXXFLAGS = @DEFAULT_CFLAGS@
+ AM_CPPFLAGS = -I$(top_srcdir) #/fflas-ffpack/utils/ -I$(top_srcdir)/fflas-ffpack/fflas/ -I$(top_srcdir)/fflas-ffpack/ffpack -I$(top_srcdir)/fflas-ffpack/field
+-LDADD = $(CBLAS_LIBS) $(GIVARO_LIBS) $(CUDA_LIBS) $(PARFLAGS)
+ #AM_LDFLAGS=-static
+
+
+@@ -55,31 +54,26 @@ libfflas_la_SOURCES= fflas_L1_inst.C \
+ fflas_L3_inst.C \
+ fflas_L3_inst_implem.inl
+
+-libfflas_la_LDFLAGS= $(LDADD) -version-info 1:0:0 \
+- -no-undefined
++libfflas_la_LIBADD= $(CBLAS_LIBS) $(GIVARO_LIBS) $(CUDA_LIBS) $(PARLIBS)
++libfflas_la_LDFLAGS= -version-info 1:0:0 -no-undefined
+
+ libffpack_la_SOURCES= ffpack_inst.C \
+ ffpack_inst_implem.inl
+-libffpack_la_LDFLAGS= $(LDADD) -version-info 1:0:0 \
+- -no-undefined $(top_builddir)/fflas-ffpack/interfaces/libs/libfflas.la
+-
+-EXTRA_libffpack_la_DEPENDENCIES= libfflas.la
++libffpack_la_LIBADD= libfflas.la
++libffpack_la_LDFLAGS= -version-info 1:0:0 -no-undefined
+
+ libfflas_c_la_SOURCES=fflas_lvl1.C \
+ fflas_lvl2.C \
+ fflas_lvl3.C \
+ fflas_sparse.C
+ #libfflas_c_la_CPPFLAGS=$(AM_CPPFLAGS) -DFFLAS_COMPILED -DFFPACK_COMPILED
+-libfflas_c_la_LDFLAGS= $(LDADD) -version-info 1:0:0 \
+- -no-undefined $(top_builddir)/fflas-ffpack/interfaces/libs/libfflas.la
+-
+-EXTRA_libfflas_c_la_DEPENDENCIES=libfflas.la
++libfflas_c_la_LIBADD= libfflas.la
++libfflas_c_la_LDFLAGS= -version-info 1:0:0 -no-undefined
+
+ libffpack_c_la_SOURCES=ffpack.C
+ #libffpack_c_la_CPPFLAGS=$(AM_CPPFLAGS) -DFFLAS_COMPILED -DFFPACK_COMPILED
+-libffpack_c_la_LDFLAGS= $(LDADD) -version-info 1:0:0 \
+- -no-undefined -lfflas -lffpack
+-EXTRA_libffpack_c_la_DEPENDENCIES=libffpack.la
++libffpack_c_la_LIBADD= libffpack.la
++libffpack_c_la_LDFLAGS= -version-info 1:0:0 -no-undefined
+
+
+ EXTRA_DIST=c_libs.doxy
+--
+2.31.1
+
diff --git a/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-fabi-version.patch b/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-fabi-version.patch
new file mode 100644
index 000000000000..48ae6c37166a
--- /dev/null
+++ b/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-fabi-version.patch
@@ -0,0 +1,31 @@
+From 11364be98b200405630117d5eebb33bfdbc8c19e Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sat, 7 Aug 2021 12:09:39 -0400
+Subject: [PATCH 1/1] configure.ac: don't append -fabi-version=6 to CXXFLAGS.
+
+This is a quick hack to avoid appending -fabi-version=6 to CXXFLAGS.
+Both givaro and fflas-ffpack have problems with this legacy cruft
+that are fixed upstream but tough to backport. We don't support
+compilers that old, so we can just delete it.
+---
+ configure.ac | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 571d923..616b2f5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -179,10 +179,6 @@ AC_SUBST(SIMD_FLAGS)
+ dnl gcc-4.9.2 bug See https://trac.sagemath.org/ticket/17635#comment:178
+ AS_IF([ test "x$CCNAM" = "xgcc492" ],[REQUIRED_FLAGS="${REQUIRED_FLAGS} -fpermissive"],[])
+
+-dnl With GCC's default ABI version, a __m128 or __m256 are the same types and therefore we cannot
+-dnl have overloads for both types without linking error.
+-AS_IF([test "x$CCNAM" = "xgcc"],[REQUIRED_FLAGS="${REQUIRED_FLAGS} -fabi-version=6"],[])
+-
+ AC_SUBST(REQUIRED_FLAGS)
+
+ PARFLAGS="${OMPFLAGS}"
+--
+2.31.1
+
diff --git a/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-test-echelon.patch b/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-test-echelon.patch
new file mode 100644
index 000000000000..0b8b68fa6093
--- /dev/null
+++ b/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-test-echelon.patch
@@ -0,0 +1,39 @@
+From 5be5c93ed41d0136730477beccad7b9f21d47e86 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Tue, 26 May 2020 09:45:50 -0400
+Subject: [PATCH 1/1] tests: disable test_echelon.
+
+There are two reported failures of test_echelon on Gentoo and Conda
+that the Gentoo maintainers haven't been able to reproduce yet. Until
+upstream has a chance to look at the failures, this commit disables
+that particular test.
+
+Gentoo-bug: https://bugs.gentoo.org/724526
+Upstream-bug: https://github.com/linbox-team/fflas-ffpack/issues/282
+---
+ tests/Makefile.am | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 4326820..62e92bc 100755
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -56,7 +56,6 @@ BASIC_TESTS = \
+ test-rankprofiles \
+ test-det \
+ test-det-check \
+- test-echelon \
+ test-charpoly \
+ test-charpoly-check \
+ test-minpoly \
+@@ -119,7 +118,6 @@ test_ftrsm_check_SOURCES = test-ftrsm-check.C
+ test_invert_check_SOURCES = test-invert-check.C
+ test_charpoly_check_SOURCES = test-charpoly-check.C
+ test_minpoly_SOURCES = test-minpoly.C
+-test_echelon_SOURCES = test-echelon.C
+ test_rankprofiles_SOURCES = test-rankprofiles.C
+ test_fgemm_SOURCES = test-fgemm.C
+ test_fger_SOURCES = test-fger.C
+--
+2.26.2
+