summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-vol
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/coinor-vol')
-rw-r--r--sci-libs/coinor-vol/Manifest6
-rw-r--r--sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild68
-rw-r--r--sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild82
-rw-r--r--sci-libs/coinor-vol/metadata.xml21
4 files changed, 97 insertions, 80 deletions
diff --git a/sci-libs/coinor-vol/Manifest b/sci-libs/coinor-vol/Manifest
index caacdfa57245..758bfb796cdf 100644
--- a/sci-libs/coinor-vol/Manifest
+++ b/sci-libs/coinor-vol/Manifest
@@ -1,3 +1,3 @@
-DIST Vol-1.4.4.tgz 3205621 BLAKE2B 187b8522d6fbcc287e3eb63e00553d2f90bb7c9add17e2ed604cef3e2ab2ba214a0d6e27ecd28457a983d0d11193ba31914f5defd841848fb9c2486d80ca4935 SHA512 20e04efac09694ddfa035496ec9b2920ef702e5a2ec4515cd88c52129c783efd3c25e044e6c2cec67ad800b297ebd03f3c3c377f58829790109d8d6dcb40cc39
-EBUILD coinor-vol-1.4.4.ebuild 1581 BLAKE2B 6a5f73df7a943d92a7722ff5af401fb797d0f53dd6145e2995f1550a38e3c59acd00ddde20d0ef3c2c71b283abe459f81327f82f640e1a45c3a70039468e6dde SHA512 12f74433fb38ed456a75c0466953afcd4fe05916608dfc214108620a354bc8d61eeb6afc62fc4ba9f58a92f6a6d01b4a32738245f25b8fd99761fb0e938dd1d2
-MISC metadata.xml 505 BLAKE2B ed047b858cd4d5ab9edb4706f5de6d7d0d327b81c0fb5a9d51a5b977468b2d2ccbc1f671c9bd5934c7c790f9d87251c52a390d5b473c2f4986edb958c3718110 SHA512 c31de615daba09af37d08828b2e58e2d6fdfeb0e6fb36b10023aa6eb04580c942103ce12b00a1ed40cddab0e2151c091dec1ce7ee65352d29685be2a07e50d0b
+DIST coinor-vol-1.5.4.tar.gz 983625 BLAKE2B b1c78f94d1232d773aa325227ac01ad469d3ff56571119ae95ddb9a34eb7d55d004111e81dc89bb4bae1b5754da29cd4e93983772e158afa131a4da0b187b03c SHA512 ba489b909dab45a9a48a32804a571fc9ad966b268ce8a81a391a743b523bce393bd649aaf15c51f401267fe05fb2ff7623a1f7208c0b9d6c24af9b659a230780
+EBUILD coinor-vol-1.5.4.ebuild 2102 BLAKE2B 1c37d117d976ccd271cc10dba41cb163ee2913586e8c65b0ecfd3a4dfaf051ca5a7322eddec1e8390b9395d83e563e489162c4f9d3d4fe8be153ca1428ac3a66 SHA512 eb65860ba325fc7f4c65d7281556ef39deb0bd223761781fe05a0ff6a27c2ebed01366d5ff07440a5cc25a073246591b2da60c72c67888ec43ca8513844a2c47
+MISC metadata.xml 599 BLAKE2B 8c6ca369668c22a14711428d81250752d9d8e0408bdb4c3c0650957df1e16a948d18777560003f25815555be1416d3d3fab52d23de342862d0fbc5f34a037e15 SHA512 2faa56ea8160351810393184d32fed0c5c3dbf18e21c1344624b7aa76d98c368a82a57a38b2c450adf96c55311e5b7aa0ad18261364ffef3e926e52aa06f88d8
diff --git a/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild b/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild
deleted file mode 100644
index ea1df608c973..000000000000
--- a/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils multilib
-
-MYPN=Vol
-
-DESCRIPTION="COIN-OR Volume algorithm linear programming solver"
-HOMEPAGE="https://projects.coin-or.org/Vol"
-SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
-
-LICENSE="EPL-1.0"
-SLOT="0/1"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- sci-libs/coinor-osi:=
- sci-libs/coinor-utils:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )
- test? ( sci-libs/coinor-sample )"
-
-S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
-
-src_prepare() {
- # needed for the --with-coin-instdir
- dodir /usr
- sed -i \
- -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
- configure || die
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-dependency-linking
- --with-coin-instdir="${ED}"/usr
- $(use_with doc dot)
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- # hack for parallel build, to overcome not patching Makefile.am above
- autotools-utils_src_compile -C src libVol.la
- autotools-utils_src_compile all $(usex doc doxydoc "")
-}
-
-src_test() {
- autotools-utils_src_test test
-}
-
-src_install() {
- use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
- autotools-utils_src_install -C src install-am
- autotools-utils_src_install
- # already installed
- rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild b/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild
new file mode 100644
index 000000000000..53276b0f38c4
--- /dev/null
+++ b/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=Vol
+
+DESCRIPTION="COIN-OR volume algorithm linear program solver"
+HOMEPAGE="https://github.com/coin-or/Vol/"
+SRC_URI="https://github.com/coin-or/${MY_PN}/archive/releases/${PV}.tar.gz
+ -> ${P}.tar.gz"
+LICENSE="EPL-1.0"
+
+# major soname component
+SLOT="0/1"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+RESTRICT="!test? ( test )"
+
+# Fortran is NOT needed, but the ./configure scripts for all of the CoinOR
+# packages contain a check for it. Gentoo bug 601648 and upstream issue,
+#
+# https://github.com/coin-or/CoinUtils/issues/132
+#
+BDEPEND="virtual/fortran
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+DEPEND="sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-releases-${PV}/${MY_PN}"
+
+src_prepare() {
+ # Needed to make the --with-coin-instdir in src_configure happy.
+ dodir /usr
+
+ # They don't need to guess at this, but they do, and get it wrong...
+ sed -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ -i configure \
+ || die "failed to fix the pkgconfig path in ${S}/configure"
+
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}/usr"
+ $(use_with doc dot)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake all $(usex doc doxydoc "")
+}
+
+src_test() {
+ # NOT redundant! The build system has a "make check" target that does
+ # nothing, so if you don't specify "test" here, you'll get a no-op.
+ emake test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+
+ emake DESTDIR="${D}" install
+
+ # Duplicate junk, and in the wrong location.
+ rm -r "${ED}/usr/share/coin/doc/${MY_PN}" || die
+
+ # Portage still throws a warning for these, but it's a bug
+ # as far as I can tell: https://bugs.gentoo.org/721516
+ docompress -x "/usr/share/doc/${PF}/examples/Volume-LP/data.mps.gz"
+ docompress -x "/usr/share/doc/${PF}/examples/VolUfl/data.gz"
+ use examples && dodoc -r examples
+}
diff --git a/sci-libs/coinor-vol/metadata.xml b/sci-libs/coinor-vol/metadata.xml
index c0e9b5e1040c..3281553a97d6 100644
--- a/sci-libs/coinor-vol/metadata.xml
+++ b/sci-libs/coinor-vol/metadata.xml
@@ -1,13 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- Volume Algorithm is part of COIN-OR (COmputational INfrastructure
- for Operations Research) project. Vol is an implementation of a
- subgradient method that produces primal as well as dual solutions.
- </longdescription>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Volume Algorithm is part of COIN-OR (COmputational INfrastructure
+ for Operations Research) project. Vol is an implementation of a
+ subgradient method that produces primal as well as dual solutions.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">coin-or/Vol</remote-id>
+ </upstream>
</pkgmetadata>