summaryrefslogtreecommitdiff
path: root/sci-libs/coinor-bcp
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/coinor-bcp')
-rw-r--r--sci-libs/coinor-bcp/Manifest3
-rw-r--r--sci-libs/coinor-bcp/coinor-bcp-1.4.4.ebuild4
-rw-r--r--sci-libs/coinor-bcp/files/coinor-bcp-1.4.4-gcc11-exceptions.patch36
3 files changed, 42 insertions, 1 deletions
diff --git a/sci-libs/coinor-bcp/Manifest b/sci-libs/coinor-bcp/Manifest
index f11f4dfc112a..2b6e7ecdf7c7 100644
--- a/sci-libs/coinor-bcp/Manifest
+++ b/sci-libs/coinor-bcp/Manifest
@@ -1,3 +1,4 @@
+AUX coinor-bcp-1.4.4-gcc11-exceptions.patch 1424 BLAKE2B 72b2890a23f15cbdfc868b9b82d9a315a7439571e9518b1fc61aa6e84f89ac199e2ff1847f3051121f7ac18dbae3dd654d4fdd7a52daa6bed3c2d9a1cef59562 SHA512 53a0010025e92c5bf099aa475fa913550723cdce99e5e46f9f96071c71e7854f896f6d26a8c3627c4ff196053b56de97ede0cea654a4df728de004846781ffa9
DIST coinor-bcp-1.4.4.tar.gz 1983573 BLAKE2B 79265c0336ca719b417825df2f27e88c08c314e599693e8886170fe69755b3272aa05469bfc069660c979e4a273ca63a25fc4d3a86a695838039121fa98a14bd SHA512 066ad631a67ccf33eebc175451f4734cbf190cb4fd9866dec987d80688a69400b76415de65ee9399b1a8ccfdf3bf3af307245610481a6d673598bc157c3963bc
-EBUILD coinor-bcp-1.4.4.ebuild 1286 BLAKE2B cacfeb014ef35c6c25d7296bce2bb975d686a1ae1ee79fba63ff3f20734283aa2b597a25994ddde5083de9a9b1b74eecb8a90de77c88a24593b7c18a323918db SHA512 6a7e1253bb1635ac0811c64162a915c5ed15d4868d561cbcbdcdd5183145e87799a6c5204136eb3303080436e2039e6552cd1e6a9cddcaf87df9c26c901f7600
+EBUILD coinor-bcp-1.4.4.ebuild 1342 BLAKE2B 3604cf8bdb00449d1f6efd365f12ef0b5d8bc21f028d8ce928c5bdde5e42a01806a40f7b47d45669f698bc2688a03b6af6e99c847b341e53557ae7cdabf3e264 SHA512 8261262187cbfa0433dc025348cfb346e31b6ca262e34e0514a3f185e29be8526a1ce85fac4dc196e4318bf13c6fb4117d62fdd9930569076efb7210d8013d13
MISC metadata.xml 754 BLAKE2B 42bb77241c68a9f2e81c4a50350fd25d42ccbab57cefc743ea0eea119b6ef530d512c89fcfc598a1f0b5ddb67ae8477c93cb61b7bddd7c242bff20acff4c57d3 SHA512 9dc6b85158dfe5ccb8820338f45c8ee1b1b7ce926ec7a41b3dae25210b99de72b87d8560e7f4a1a0772a35f5cabc2fa261fc0044e0d4c5c826f0c61034b8b6cd
diff --git a/sci-libs/coinor-bcp/coinor-bcp-1.4.4.ebuild b/sci-libs/coinor-bcp/coinor-bcp-1.4.4.ebuild
index b4b5f58fbe9e..a904acfd1336 100644
--- a/sci-libs/coinor-bcp/coinor-bcp-1.4.4.ebuild
+++ b/sci-libs/coinor-bcp/coinor-bcp-1.4.4.ebuild
@@ -25,6 +25,10 @@ BDEPEND="
doc? ( app-doc/doxygen[dot] )
test? ( sci-libs/coinor-sample )"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc11-exceptions.patch
+)
+
src_prepare() {
default
# Prevent unneeded call to pkg-config that needs ${ED}'s in path.
diff --git a/sci-libs/coinor-bcp/files/coinor-bcp-1.4.4-gcc11-exceptions.patch b/sci-libs/coinor-bcp/files/coinor-bcp-1.4.4-gcc11-exceptions.patch
new file mode 100644
index 000000000000..d37e8b024396
--- /dev/null
+++ b/sci-libs/coinor-bcp/files/coinor-bcp-1.4.4-gcc11-exceptions.patch
@@ -0,0 +1,36 @@
+https://github.com/coin-or/Bcp/commit/e581a2dd4b55352eb318c15e8281b3cc9d8abe23.patch
+https://bugs.gentoo.org/786306
+
+From e581a2dd4b55352eb318c15e8281b3cc9d8abe23 Mon Sep 17 00:00:00 2001
+From: Julien Schueller <schueller@phimeca.com>
+Date: Fri, 14 Aug 2020 09:58:47 +0200
+Subject: [PATCH] Fix deprecated dynamic exception warning
+
+warning: dynamic exception specifications are deprecated in C++11
+--- a/src/include/BCP_buffer.hpp
++++ b/src/include/BCP_buffer.hpp
+@@ -101,13 +101,13 @@ class BCP_buffer{
+ /**@name Modifying methods */
+ /*@{*/
+ /** Position the read head in the buffer. Must be between 0 and size(). */
+- inline void set_position(const int pos) throw(BCP_fatal_error) {
++ inline void set_position(const int pos) {
+ if (pos < 0 || pos > size())
+ throw BCP_fatal_error("Incorrest buffer position setting.\n");
+ _pos = pos;
+ }
+ /** Cut off the end of the buffer. Must be between 0 and size(). */
+- inline void set_size(const int s) throw(BCP_fatal_error) {
++ inline void set_size(const int s) {
+ if (s < 0 || s > size())
+ throw BCP_fatal_error("Incorrest buffer position setting.\n");
+ _size = s;
+@@ -221,7 +221,7 @@ class BCP_buffer{
+ */
+ template <class T> BCP_buffer& unpack(T*& values, int& length,
+ bool allocate = true)
+- throw(BCP_fatal_error) {
++ {
+ if (allocate) {
+ #ifdef PARANOID
+ if (_pos + sizeof(int) > _size)