summaryrefslogtreecommitdiff
path: root/sci-libs/ceres-solver
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/ceres-solver')
-rw-r--r--sci-libs/ceres-solver/Manifest2
-rw-r--r--sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild99
2 files changed, 0 insertions, 101 deletions
diff --git a/sci-libs/ceres-solver/Manifest b/sci-libs/ceres-solver/Manifest
index c127ff81893c..182ead837c65 100644
--- a/sci-libs/ceres-solver/Manifest
+++ b/sci-libs/ceres-solver/Manifest
@@ -1,6 +1,4 @@
AUX ceres-solver-2.0.0-system-mathjax.patch 325 BLAKE2B a649088517ec1bef7d5a6144de57657daeff2b5a1a0b053c0bfa81d8af7143ad5d829571be947d8853bd6d1fe39adc63b4f14a4075004775151fa649747911c6 SHA512 e16646210fddb350f5cc43665afaa88d2ffe53c817dab778c0e2534c1a0001242865a547e8a308621a9068555e7e20a57e83b0447ff5d32688ed5fb3f5694d29
-DIST ceres-solver-2.0.0.tar.gz 11225245 BLAKE2B 1761908747d460f6a84cb519b4bbb49fec7e1e36cc616b438c45ace57d10bd3bb4d0cb2795e07d5096e0b9453511c185ffdd3872e317aa8095daeb86933643b0 SHA512 843b19389f4d628b2b8b8538655cb330e092ffcc960c6896c6e3065b3a34e330c81e993b7abcd754e575742e2104087efde3526945c92f7df3f6b700984e49f9
DIST ceres-solver-2.1.0.tar.gz 3802187 BLAKE2B d8ff780cf9b9de2541c15a2b95bde07a2d1c8e60bab3a8a4b13134b99da699da452467afe3310b9f70c3c2a6bd033ea3c4bd3c401153899e9c70867fae30c633 SHA512 db777c4a4b85a9972628c714413fe9ca1a92cc6c8b14d80401842a02c4d7e7df4e9d236775e231e8337e47f21e47cd82c1a0fbcfeffbd9b654e46a66262996f2
-EBUILD ceres-solver-2.0.0.ebuild 2414 BLAKE2B 9ef712cd5bc0e9ea9cbba26cfac19576c808eeb429ff56755be4d5363ba51c6ff0783e76a77184e51a3148d8f6d51576a7975b7bd15bab44a4e63febe18dd8b3 SHA512 8a0e8300fccade8371ef334a77b081e08cb1882fb350de09c10c2b1ff03fc1ba5f61d7885c4474a8c51c5e1732c06b8934e042fe032f015e5dce91f2d5eb0eae
EBUILD ceres-solver-2.1.0.ebuild 2423 BLAKE2B 793bdd2f1b78d4328d0a84a39ccb4961882f4cec09243ebdaef23dd3af6c971d44c43cc9400ea9989d973aa8cc352b483ef69ec516e7d95fba52c4365f8dfe12 SHA512 926498979b515a0e35cbb5b9551cbd7dda2cbf1dc36aef6f4617cb3595e4f493446e026ba0344a3703beea9ea410a6bc80312e505c143a2e9769ec0b493b0694
MISC metadata.xml 1454 BLAKE2B af5a9cef52650cff056c7804782e7024696ed9122e8998faad23796960d94155f5f318cec2750a4ead6610f89fe55e49301a30ec62bfc846ea2a955a430f42cf SHA512 cf928d9400bbac7ba003ad44fc6c1d77cef43a58d2cc9b399ee854880ad75b38062e3a61899403eda529e7eaba528606a8da25b5e287c53bc4721d025b6a7e59
diff --git a/sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild b/sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild
deleted file mode 100644
index 684d229cf029..000000000000
--- a/sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-DOCS_BUILDER="sphinx"
-DOCS_DEPEND="dev-python/sphinx_rtd_theme"
-DOCS_DIR="docs/source"
-inherit cmake-multilib python-any-r1 docs toolchain-funcs
-
-DESCRIPTION="Nonlinear least-squares minimizer"
-HOMEPAGE="http://ceres-solver.org/"
-SRC_URI="http://ceres-solver.org/${P}.tar.gz"
-
-LICENSE="sparse? ( BSD ) !sparse? ( LGPL-2.1 ) cxsparse? ( BSD )"
-SLOT="0/1"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cxsparse examples gflags lapack openmp +schur sparse test"
-
-REQUIRED_USE="test? ( gflags ) sparse? ( lapack ) abi_x86_32? ( !sparse !lapack )"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="${PYTHON_DEPS}
- >=dev-cpp/eigen-3.3.4:3
- lapack? ( virtual/pkgconfig )
- doc? ( dev-libs/mathjax )
-"
-RDEPEND="
- dev-cpp/glog[gflags?,${MULTILIB_USEDEP}]
- cxsparse? ( sci-libs/cxsparse )
- lapack? ( virtual/lapack )
- sparse? (
- sci-libs/amd
- sci-libs/camd
- sci-libs/ccolamd
- sci-libs/cholmod[metis(+)]
- sci-libs/colamd
- sci-libs/spqr
- )
-"
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md VERSION )
-
-PATCHES=( "${FILESDIR}/${P}-system-mathjax.patch" )
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- use doc && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # search paths work for prefix
- sed -e "s:/usr:${EPREFIX}/usr:g" \
- -i cmake/*.cmake || die
-
- # remove Werror
- sed -e 's/-Werror=(all|extra)//g' \
- -i CMakeLists.txt || die
-}
-
-src_configure() {
- # CUSTOM_BLAS=OFF EIGENSPARSE=OFF MINIGLOG=OFF CXX11=OFF
- local mycmakeargs=(
- -DBUILD_BENCHMARKS=OFF
- -DBUILD_EXAMPLES=$(usex examples)
- -DBUILD_TESTING=$(usex test)
- -DBUILD_DOCUMENTATION=$(usex doc)
- -DGFLAGS=$(usex gflags)
- -DLAPACK=$(usex lapack)
- -DSCHUR_SPECIALIZATIONS=$(usex schur)
- -DCXSPARSE=$(usex cxsparse)
- -DSUITESPARSE=$(usex sparse)
- -DEigen3_DIR=/usr/$(get_libdir)/cmake/eigen3
- -DCERES_THREADING_MODEL=$(usex openmp OPENMP CXX_THREADS)
- )
- use doc && mycmakeargs+=(
- -DCERES_DOCS_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${PF}
- )
- use sparse || use cxsparse || mycmakeargs+=( -DEIGENSPARSE=ON )
- cmake-multilib_src_configure
-}
-
-src_install() {
- cmake-multilib_src_install
-
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples data
- fi
-}