summaryrefslogtreecommitdiff
path: root/sci-libs/amd
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/amd')
-rw-r--r--sci-libs/amd/Manifest2
-rw-r--r--sci-libs/amd/amd-2.4.6-r1.ebuild42
-rw-r--r--sci-libs/amd/files/amd-2.4.6-dash_doc.patch16
3 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/amd/Manifest b/sci-libs/amd/Manifest
index 0d258d6db8d7..6102e828f628 100644
--- a/sci-libs/amd/Manifest
+++ b/sci-libs/amd/Manifest
@@ -1,3 +1,5 @@
+AUX amd-2.4.6-dash_doc.patch 488 BLAKE2B ed5872a7b0a2dc90bf69a2c74db9dc9379afd54831c87ce4ba577a3d70f2a5f2cdcda1a8ea2b1932974c18a45ab6b8043d0de8217054464881476c2041ca1e29 SHA512 7ac31c0b64b3986c6c6e44babe326c385eacb8a4a5c542ea1e7bf8b566eceb3e70a3d3cdf48a783507c9ecc1b21b53487523838d8f2936e0d2cbae688e30bee2
DIST amd-2.4.6.tar.bz2 343925 BLAKE2B 296579d888b61e84ec798206fbb6f89fd923f0d762e84e7a1e2e2a5fb502f4822f89a2a4b631dc42fa829e845bf3980886185650e8de28774400e0c351805061 SHA512 6960a557e6c2f82ca2e68e48ddcb502e1527235a3ca34df2f5f7f63f0f12afacedb15fefe4a39768fe7a2c70308793544b5b24b6f2be2c6b934b0c0e0e796d57
+EBUILD amd-2.4.6-r1.ebuild 882 BLAKE2B 413aaf0223555573845255dac5f88ac55a8c4022e24d846bd6df47205138662f4986749da81b801a81e4e0398d1bde1deb8dc2d51456288f112501e42f3076b8 SHA512 8762ebf0c74d940adbcddfa93ab711ae27d972d01f984bee72851700c4fc8295c2ff03f5c98950f03521d3d08ff07a0f45e857df13d7c840eac51fe72af226b2
EBUILD amd-2.4.6.ebuild 770 BLAKE2B b4cd6552357a25f2bb55316203cd34af09909621a7336d3f6eb03af974d2fe00193b0459536af8d4d961c41f769ae77131395a568b75823ec05c40efbc7d61bb SHA512 1608629f558dc14a4cf4a99beeb9973b9475332902311e16cdc0fff2a51f0b950ff5e6f64f602190cb4c76481eac0425f2c665171ec68531c445c984989641ed
MISC metadata.xml 492 BLAKE2B ac6367af33dd797e703e3370d6369db5286b11f862b5387258e9edd860554049c7d9e2bf2186c86e24a7fc29c3f1122f330c0a3cf0420f13085757cff0a388b3 SHA512 1c53658e87337e1e43149c363c901dabfdde52b647891d8026a7ce9ddcd5e36b0121948d169d446e5a78d05c26301bd4f8c7c06665506ebc0999c259b709a6b6
diff --git a/sci-libs/amd/amd-2.4.6-r1.ebuild b/sci-libs/amd/amd-2.4.6-r1.ebuild
new file mode 100644
index 000000000000..f03f2eaa63da
--- /dev/null
+++ b/sci-libs/amd/amd-2.4.6-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fortran-2
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+DEPEND=">=sci-libs/suitesparseconfig-5.4.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.4.6-dash_doc.patch )
+
+src_prepare(){
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable fortran) \
+ $(use_with doc)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/amd/files/amd-2.4.6-dash_doc.patch b/sci-libs/amd/files/amd-2.4.6-dash_doc.patch
new file mode 100644
index 000000000000..62d9071422ce
--- /dev/null
+++ b/sci-libs/amd/files/amd-2.4.6-dash_doc.patch
@@ -0,0 +1,16 @@
+diff --git a/Doc/Makefile.am b/Doc/Makefile.am
+index 44361ff..039b02f 100644
+--- a/Doc/Makefile.am
++++ b/Doc/Makefile.am
+@@ -1,9 +1,8 @@
+
+ AMD_UserGuide.pdf:
+- echo '\begin{verbatim}' > amd_h.tex
++ printf '\\begin{verbatim}\n' > amd_h.tex
+ expand -8 $(top_srcdir)/Include/amd.h >> amd_h.tex
+- echo '\end{verbatim}' >> amd_h.tex
+- -ln -s $(srcdir)/*.{tex,bib} .
++ printf '\\end{verbatim}\n' >> amd_h.tex
+ $(PDFLATEX) AMD_UserGuide
+ $(BIBTEX) AMD_UserGuide
+ $(PDFLATEX) AMD_UserGuide