summaryrefslogtreecommitdiff
path: root/sci-libs/adolc/adolc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/adolc/adolc-9999.ebuild')
-rw-r--r--sci-libs/adolc/adolc-9999.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/sci-libs/adolc/adolc-9999.ebuild b/sci-libs/adolc/adolc-9999.ebuild
index eeaa03bdcee1..b4eaac107e7c 100644
--- a/sci-libs/adolc/adolc-9999.ebuild
+++ b/sci-libs/adolc/adolc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,6 +11,7 @@ HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/coin-or/ADOL-C"
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-2.7.2-patches.tar.bz2"
else
SRC_URI="https://github.com/coin-or/ADOL-C/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
@@ -28,18 +29,24 @@ RDEPEND="
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-2.5.0-no-colpack.patch
- "${FILESDIR}"/${PN}-2.5.0-pkgconfig-no-ldflags.patch
- "${FILESDIR}"/${PN}-2.6.2-dash.patch
+ "${WORKDIR}"/${PN}-2.5.0-no-colpack.patch
+ "${WORKDIR}"/${PN}-2.5.0-pkgconfig-no-ldflags.patch
+ "${WORKDIR}"/${PN}-2.6.2-dash.patch
)
+src_unpack() {
+ git-r3_src_unpack
+ default
+}
+
src_prepare() {
default
eautoreconf
}
src_configure() {
- econf \
+ # Can drop CONFIG_SHELL once fixed up dash/bashisms patch
+ CONFIG_SHELL="${BROOT}/bin/bash" econf \
--disable-python \
--disable-static \
--enable-advanced-branching \