summaryrefslogtreecommitdiff
path: root/sci-libs/adolc/adolc-2.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/adolc/adolc-2.7.2.ebuild')
-rw-r--r--sci-libs/adolc/adolc-2.7.2.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-libs/adolc/adolc-2.7.2.ebuild b/sci-libs/adolc/adolc-2.7.2.ebuild
index 0f101d7e1fbb..009ee6a78ed3 100644
--- a/sci-libs/adolc/adolc-2.7.2.ebuild
+++ b/sci-libs/adolc/adolc-2.7.2.ebuild
@@ -13,6 +13,7 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/coin-or/ADOL-C"
else
SRC_URI="https://github.com/coin-or/ADOL-C/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-2.7.2-patches.tar.bz2"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/ADOL-C-releases-${PV}"
fi
@@ -28,10 +29,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-2.5.0-no-colpack.patch
- "${FILESDIR}"/${PN}-2.5.0-pkgconfig-no-ldflags.patch
- "${FILESDIR}"/${PN}-2.6.2-dash.patch
- "${FILESDIR}"/${P}-swig-python-configure.patch
+ "${WORKDIR}"/${PN}-2.5.0-no-colpack.patch
+ "${WORKDIR}"/${PN}-2.5.0-pkgconfig-no-ldflags.patch
+ "${WORKDIR}"/${PN}-2.6.2-dash.patch
+ "${WORKDIR}"/${P}-swig-python-configure.patch
)
src_prepare() {
@@ -44,7 +45,8 @@ src_configure() {
# needs work. Revisit with >=2.7.3.
# https://bugs.gentoo.org/730750
# https://github.com/coin-or/ADOL-C/issues/20
- econf \
+ # Can drop CONFIG_SHELL once fixed up dash/bashisms patch
+ CONFIG_SHELL="${BROOT}/bin/bash" econf \
--disable-python \
--disable-static \
--enable-advanced-branching \