summaryrefslogtreecommitdiff
path: root/sci-geosciences/qgis/qgis-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/qgis/qgis-9999.ebuild')
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild36
1 files changed, 18 insertions, 18 deletions
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index d7f5ec4633f4..5c5913d97ad0 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="sqlite"
if [[ ${PV} = *9999* ]]; then
@@ -72,23 +72,23 @@ COMMON_DEPEND="
python? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
- dev-python/future[${PYTHON_MULTI_USEDEP}]
- dev-python/httplib2[${PYTHON_MULTI_USEDEP}]
- dev-python/jinja[${PYTHON_MULTI_USEDEP}]
- dev-python/markupsafe[${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
- dev-python/owslib[${PYTHON_MULTI_USEDEP}]
- dev-python/pygments[${PYTHON_MULTI_USEDEP}]
- dev-python/PyQt5[designer,network,sql,svg,${PYTHON_MULTI_USEDEP}]
- dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
- dev-python/pytz[${PYTHON_MULTI_USEDEP}]
- dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
- >=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
- <dev-python/sip-5:=[${PYTHON_MULTI_USEDEP}]
- dev-python/six[${PYTHON_MULTI_USEDEP}]
- >=sci-libs/gdal-2.2.3[python,${PYTHON_MULTI_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}] )
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/owslib[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[designer,network,sql,svg,${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.10.1[qt5(+),${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/sip-5:=[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sci-libs/gdal-2.2.3[python,${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
')
)
qml? ( dev-qt/qtdeclarative:5 )