summaryrefslogtreecommitdiff
path: root/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild')
-rw-r--r--sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild
new file mode 100644
index 000000000000..2d4a9d906c36
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-weather_routing/opencpn-plugin-weather_routing-1.13.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit cmake wxwidgets
+
+MY_PN="weather_routing_pi"
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rgleason/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/rgleason/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Weather Routing Plugin for OpenCPN"
+HOMEPAGE="https://github.com/rgleason/weather_routing_pi/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ setup-wxwidgets unicode
+ cmake_src_configure
+}