summaryrefslogtreecommitdiff
path: root/sci-geosciences/grass/grass-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/grass/grass-9999.ebuild')
-rw-r--r--sci-geosciences/grass/grass-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-geosciences/grass/grass-9999.ebuild b/sci-geosciences/grass/grass-9999.ebuild
index 31ad3a913914..33808453c9c7 100644
--- a/sci-geosciences/grass/grass-9999.ebuild
+++ b/sci-geosciences/grass/grass-9999.ebuild
@@ -13,7 +13,7 @@ DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizu
HOMEPAGE="https://grass.osgeo.org/"
LICENSE="GPL-2"
-SLOT="0/8.1"
+SLOT="0/8.3"
GVERSION=${SLOT#*/}
MY_PM="${PN}${GVERSION}"
@@ -32,7 +32,7 @@ else
S="${WORKDIR}/${MY_P}"
fi
-IUSE="blas cxx fftw geos lapack liblas mysql netcdf nls odbc opencl opengl openmp png postgres readline sqlite threads tiff truetype X zstd"
+IUSE="blas cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp png postgres readline sqlite threads tiff truetype X zstd"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
opengl? ( X )"
@@ -59,7 +59,7 @@ RDEPEND="
fftw? ( sci-libs/fftw:3.0= )
geos? ( sci-libs/geos:= )
lapack? ( virtual/lapack[eselect-ldso(+)] )
- liblas? ( sci-geosciences/liblas )
+ las? ( sci-geosciences/liblas )
mysql? ( dev-db/mysql-connector-c:= )
netcdf? ( sci-libs/netcdf:= )
odbc? ( dev-db/unixODBC )
@@ -179,7 +179,7 @@ src_configure() {
$(use_with threads pthread)
$(use_with openmp)
$(use_with opencl)
- $(use_with liblas liblas "${EPREFIX}"/usr/bin/liblas-config)
+ $(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
$(use_with X wxwidgets "${WX_CONFIG}")
$(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)
$(use_with geos geos "${EPREFIX}"/usr/bin/geos-config)
@@ -269,6 +269,8 @@ os.environ\[\"GRASS_PYTHON\"\] = \"${EPYTHON}\":" \
pkg_postinst() {
use X && xdg_pkg_postinst
+ ewarn 'Starting with version 8.0.2 the "liblas" USE flag has been renamed'
+ ewarn 'to "las" in order to match dev-games/openscenegraph (Bug 680854)'
}
pkg_postrm() {