summaryrefslogtreecommitdiff
path: root/sci-geosciences/grass/grass-8.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/grass/grass-8.3.1.ebuild')
-rw-r--r--sci-geosciences/grass/grass-8.3.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sci-geosciences/grass/grass-8.3.1.ebuild b/sci-geosciences/grass/grass-8.3.1.ebuild
index 166049f1b309..8a3ea23d393d 100644
--- a/sci-geosciences/grass/grass-8.3.1.ebuild
+++ b/sci-geosciences/grass/grass-8.3.1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="sqlite" # bug 572440
-inherit desktop python-single-r1 toolchain-funcs xdg
+inherit desktop flag-o-matic python-single-r1 toolchain-funcs xdg
DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
HOMEPAGE="https://grass.osgeo.org/"
@@ -163,6 +163,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862579
+ # https://github.com/OSGeo/grass/issues/3506
+ #
+ # Do not trust it with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
addwrite /dev/dri/renderD128
local myeconfargs=(