summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpsd/gpsd-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/gpsd/gpsd-9999.ebuild')
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 456c84a9790f..4e8c7af4c741 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{8,9,10} )
SCONS_MIN_VERSION="2.3.0"
-inherit udev distutils-r1 scons-utils toolchain-funcs
+inherit udev distutils-r1 scons-utils systemd toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
@@ -146,7 +146,7 @@ src_configure() {
gpsd_group=dialout
nostrip=True
systemd=$(usex systemd)
- unitdir="\$prefix/$(get_libdir)"
+ unitdir="$(systemd_get_systemunitdir)"
shared=$(usex !static True False)
bluez=$(usex bluetooth)
libgpsmm=$(usex cxx)