summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpsd/gpsd-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/gpsd/gpsd-9999.ebuild')
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 48a28860d3c8..7c4fb91cc9fa 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{8,9,10} )
SCONS_MIN_VERSION="2.3.0"
-inherit udev distutils-r1 scons-utils systemd toolchain-funcs
+inherit distutils-r1 scons-utils systemd toolchain-funcs udev
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
@@ -25,9 +25,8 @@ SLOT="0/29"
GPSD_PROTOCOLS=(
aivdm ashtech earthmate evermore fury fv18 garmin garmintxt geostar
- gpsclock greis isync itrax mtk3301 navcom nmea0183 nmea2000 ntrip
- oceanserver oncore passthrough rtcm104v2 rtcm104v3 sirf skytraq
- superstar2 tnt tripmate tsip ublox
+ gpsclock greis isync itrax navcom nmea2000 oceanserver oncore
+ rtcm104v2 rtcm104v3 sirf skytraq superstar2 tnt tripmate tsip ublox
)
IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/+gpsd_protocols_}
IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth +cxx dbus debug ipv6 latency-timing ncurses ntp +python qt5 +shm +sockets static systemd test udev usb X"
@@ -101,6 +100,9 @@ src_prepare() {
python_prepare_all() {
python_setup
+ # bug #796476
+ python_export_utf8_locale
+
# Extract python info out of SConscript so we can use saner distribute
pyarray() { sed -n "/^ *$1 *= *\\[/,/\\]/p" SConscript ; }
local pyprogs=$(pyarray python_progs)
@@ -196,6 +198,15 @@ src_compile() {
popd || die
}
+src_test() {
+ escons "${scons_opts[@]}" check
+}
+
+python_test() {
+ # Silence QA check which gets confused by layout(?). We do run the tests.
+ :;
+}
+
src_install() {
DESTDIR="${D}" escons install "${scons_opts[@]}" $(usex udev udev-install '')
@@ -210,3 +221,7 @@ src_install() {
use python && distutils-r1_src_install
popd || die
}
+
+pkg_postinst() {
+ use udev && udev_reload
+}