summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpscorrelate/files/gpscorrelate-2.0-respect-users-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/gpscorrelate/files/gpscorrelate-2.0-respect-users-flags.patch')
-rw-r--r--sci-geosciences/gpscorrelate/files/gpscorrelate-2.0-respect-users-flags.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-geosciences/gpscorrelate/files/gpscorrelate-2.0-respect-users-flags.patch b/sci-geosciences/gpscorrelate/files/gpscorrelate-2.0-respect-users-flags.patch
new file mode 100644
index 000000000000..31519848a7a2
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/files/gpscorrelate-2.0-respect-users-flags.patch
@@ -0,0 +1,30 @@
+diff --git a/Makefile b/Makefile
+index 7634553..9bfd025 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,12 +2,12 @@
+
+ PACKAGE_VERSION = 2.0
+
+-CC = gcc
+-CXX = g++
++CC ?= gcc
++CXX ?= g++
+ EXEEXT =
+-PKG_CONFIG=pkg-config
+-CFLAGS = -Wall -O2
+-LDFLAGS = -Wall -O2 -lm
++PKG_CONFIG?=pkg-config
++CFLAGS ?= -Wall -O2
++LDFLAGS ?= -Wall -O2
+ GTK = 3
+
+ COBJS = main-command.o unixtime.o gpx-read.o correlate.o exif-gps.o latlong.o
+@@ -20,6 +20,7 @@ CFLAGSINC = `$(PKG_CONFIG) --cflags libxml-2.0 exiv2`
+ GTKFLAGS = `$(PKG_CONFIG) --cflags gtk+-$(GTK).0`
+ LIBS = `$(PKG_CONFIG) --libs libxml-2.0 exiv2`
+ LIBSGUI = `$(PKG_CONFIG) --libs gtk+-$(GTK).0`
++LIBS += -lm -lstdc++
+
+ CFLAGSINC += $(GTKFLAGS)
+