summaryrefslogtreecommitdiff
path: root/sci-geosciences/geopy/geopy-2.3.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/geopy/geopy-2.3.0-r2.ebuild')
-rw-r--r--sci-geosciences/geopy/geopy-2.3.0-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-geosciences/geopy/geopy-2.3.0-r2.ebuild b/sci-geosciences/geopy/geopy-2.3.0-r2.ebuild
new file mode 100644
index 000000000000..33a688f525c5
--- /dev/null
+++ b/sci-geosciences/geopy/geopy-2.3.0-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python client for several popular geocoding web services"
+HOMEPAGE="https://github.com/geopy/geopy"
+SRC_URI="https://github.com/geopy/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# Need geocoding service to test
+RESTRICT="test"
+
+RDEPEND=">=sci-geosciences/GeographicLib-1.51-r1[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""