summaryrefslogtreecommitdiff
path: root/sci-geosciences/geopy/geopy-2.3.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-11 22:30:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-11 22:30:49 +0100
commit146120220e830d8902860e18cdb15b23c5b575b8 (patch)
tree1e3346a230a3c4a71944940ac918d70580459753 /sci-geosciences/geopy/geopy-2.3.0-r2.ebuild
parent788bcc2dc1910a097d019f25e3e70dc7b4fdc903 (diff)
gentoo auto-resync : 11:07:2023 - 22:30:49
Diffstat (limited to 'sci-geosciences/geopy/geopy-2.3.0-r2.ebuild')
-rw-r--r--sci-geosciences/geopy/geopy-2.3.0-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-geosciences/geopy/geopy-2.3.0-r2.ebuild b/sci-geosciences/geopy/geopy-2.3.0-r2.ebuild
new file mode 100644
index 000000000000..33a688f525c5
--- /dev/null
+++ b/sci-geosciences/geopy/geopy-2.3.0-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python client for several popular geocoding web services"
+HOMEPAGE="https://github.com/geopy/geopy"
+SRC_URI="https://github.com/geopy/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# Need geocoding service to test
+RESTRICT="test"
+
+RDEPEND=">=sci-geosciences/GeographicLib-1.51-r1[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""