summaryrefslogtreecommitdiff
path: root/sci-geosciences/geopy/geopy-2.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/geopy/geopy-2.2.0.ebuild')
-rw-r--r--sci-geosciences/geopy/geopy-2.2.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-geosciences/geopy/geopy-2.2.0.ebuild b/sci-geosciences/geopy/geopy-2.2.0.ebuild
new file mode 100644
index 000000000000..0eca56b94d75
--- /dev/null
+++ b/sci-geosciences/geopy/geopy-2.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for several popular geocoding web services"
+HOMEPAGE="https://github.com/geopy/geopy"
+SRC_URI="https://github.com/geopy/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# Need geocoding service to test
+RESTRICT="test"
+
+RDEPEND=">=sci-geosciences/GeographicLib-1.51-r1[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""