summaryrefslogtreecommitdiff
path: root/sci-electronics/splat
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/splat')
-rw-r--r--sci-electronics/splat/Manifest4
-rw-r--r--sci-electronics/splat/files/splat-1.2.2-gcc43.patch4
-rw-r--r--sci-electronics/splat/splat-1.4.2.ebuild55
3 files changed, 32 insertions, 31 deletions
diff --git a/sci-electronics/splat/Manifest b/sci-electronics/splat/Manifest
index e2663e144dc4..7db09c2feb4f 100644
--- a/sci-electronics/splat/Manifest
+++ b/sci-electronics/splat/Manifest
@@ -1,4 +1,4 @@
-AUX splat-1.2.2-gcc43.patch 205 BLAKE2B f145e08d07cf755914700690737f6ebc4230c598083495d1abe99586fa4302fd5e361c5277fe3daf494686e2ea551941f4a32c953f2f4c407474f2ba2ebac357 SHA512 ce99a5688305cc0bc53544b8c57cd73d3a9ccaaa7bce1115f63ee79c93c06f9ec80d694fcedcbded35b1f12d9b8b1d79022de7afb7fa43980710c4928c6dcf21
+AUX splat-1.2.2-gcc43.patch 180 BLAKE2B 9f6101e7fc1625e0660f871079da0d072b12d6514f57afd71be8c7c521f0098768ae70dfc103831803dcc7a96d545c897abca4ca110d49e310eb983a18292225 SHA512 01ecd4cd08575d354c94d78e02c9117ef613e71664f7fed9b64239907051f4170e56dc9dc9368ec08fa67d81fdc9bb67805e3eacb7c40a9663e52dd2d81d0638
DIST splat-1.4.2.tar.bz2 356823 BLAKE2B 7e4fe835128ae88b6d44d87159a5eab8652eed26876a637e613f57177ebfca8df7433455b53124318a2a0277bd09ca2cb9ce74ab205f5c6d1417fa736934b3fa SHA512 223b6184b1df35052709ba3b0e8679b9f6a2933c98ac433b0f07cd93b07213f55399a6eeb8e955a86fb59d13e09d891fc085ac17594f561268da239c30e885bb
-EBUILD splat-1.4.2.ebuild 2406 BLAKE2B 172d56cfcbd32ffa51e442f8ce3e9af80c6e6b78bec38c7808c7ba4eb9f2241c4def7fb5f981a9970193b738cfcd16b230a99ba2eb5a90ca148de7983eed9ec4 SHA512 ad5ae8dfcf7db3356bf958ad99be9faaf14ffb61299334cc46c74d4ad73cba8d8bd5c2ee1be9d36235afada02373fff3ae0c1a0943f19872852369653202dc81
+EBUILD splat-1.4.2.ebuild 2114 BLAKE2B cc1973f7cdb66137addc32f89f32f5349819110f8c41a21c49cdfd9fe354bc591fcbbabfe1214a433244da51f050d8f478872dc8ffe2c48730c37f67c7530c9e SHA512 5812f517eae1bea8c5a222adbd56a7b0f0a2f4fd94bc5032bb6d179d460650fe41621b45e7ee354c7ef0427fe3c8af7fe1f4b5fc12e07738392d996d9f12a499
MISC metadata.xml 740 BLAKE2B 20f01ab6e9fb164deaf70b2e0442a3d5c0df7131197da4e9a07c9928f14124e2d803a7779ddbd43d2d714ee57b48086ddd04c86bbe1dd4e565395f9eeede9a29 SHA512 7aae74c935e1a47b38e5bcbc08348e954625c5eb21fee593ab5d2662bcc2724f40ca4c62bc58145c9856b1a4167f23ce4b27c930f43eea4089f0edddcb1e82ee
diff --git a/sci-electronics/splat/files/splat-1.2.2-gcc43.patch b/sci-electronics/splat/files/splat-1.2.2-gcc43.patch
index 11e65e77f14a..be906150b9fd 100644
--- a/sci-electronics/splat/files/splat-1.2.2-gcc43.patch
+++ b/sci-electronics/splat/files/splat-1.2.2-gcc43.patch
@@ -1,5 +1,5 @@
---- splat-1.2.1.orig/utils/fontdata.c
-+++ splat-1.2.1/utils/fontdata.c
+--- a/utils/fontdata.c
++++ b/utils/fontdata.c
@@ -32,6 +32,7 @@
#include <string.h>
#include <stdlib.h>
diff --git a/sci-electronics/splat/splat-1.4.2.ebuild b/sci-electronics/splat/splat-1.4.2.ebuild
index d9bb7221cd65..8a0b78e7f312 100644
--- a/sci-electronics/splat/splat-1.4.2.ebuild
+++ b/sci-electronics/splat/splat-1.4.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="RF Signal Propagation, Loss, And Terrain analysis tool"
HOMEPAGE="https://www.qsl.net/kd2bd/splat.html"
@@ -14,18 +14,20 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc hires l10n_es"
-DEPEND="sys-libs/zlib
- app-arch/bzip2"
+DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.2.2-gcc43.patch"
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.2-gcc43.patch
+)
src_configure() {
# fake resulting file from interactive configuration script
# using default resolution
- cat <<- EOF > "${S}/splat.h"
+ cat <<- EOF > "${S}/splat.h" || die
/* Parameters for 3 arc-second standard resolution mode of operation */
#define MAXPAGES 9
#define HD_MODE 0
@@ -33,7 +35,7 @@ src_configure() {
if use hires; then
# fake resulting file from interactive configuration script
# using default resolution
- cat <<- EOF > "${S}/hires.h"
+ cat <<- EOF > "${S}/hires.h" || die
/* Parameters for 3 arc-second hires resolution mode of operation */
#define MAXPAGES 9
#define HD_MODE 1
@@ -42,20 +44,21 @@ src_configure() {
}
src_compile() {
- local CC=$(tc-getCC) CXX=$(tc-getCXX)
+ tc-export CC CXX
- ${CXX} -Wall ${CXXFLAGS} ${LDFLAGS} itwom3.0.cpp splat.cpp -o rfsplat -lm -lbz2 || die
+ cp {splat,rfsplat}.cpp || die
+ emake LDLIBS="-lm -lbz2" -E "rfsplat: itwom3.0.o"
if use hires; then
- cp "${S}/hires.h" "${S}/splat.h"
- ${CXX} -Wall ${CXXFLAGS} ${LDFLAGS} itwom3.0.cpp splat.cpp -o rfsplat-hd -lm -lbz2 || die
+ cp {hires,splat}.h || die
+ cp {splat,rfsplat-hd}.cpp || die
+ emake LDLIBS="-lm -lbz2" -E "rfsplat-hd: itwom3.0.o"
fi
- cd utils
- ${CC} -Wall ${CFLAGS} ${LDFLAGS} citydecoder.c -o citydecoder
- ${CC} -Wall ${CFLAGS} ${LDFLAGS} usgs2sdf.c -o usgs2sdf
- ${CC} -Wall ${CFLAGS} ${LDFLAGS} srtm2sdf.c -o srtm2sdf -lbz2
- #${CC} -Wall ${CFLAGS} ${LDFLAGS} fontdata.c -o fontdata -lz
- ${CC} -Wall ${CFLAGS} ${LDFLAGS} bearing.c -o bearing -lm
+ cd utils || die
+
+ emake citydecoder usgs2sdf
+ emake LDLIBS=-lbz2 srtm2sdf
+ emake LDLIBS=-lm bearing
}
src_install() {
@@ -63,9 +66,8 @@ src_install() {
use l10n_es && SPLAT_LANG="spanish"
# splat binary
dobin rfsplat
- if use hires; then
- dobin rfsplat-hd
- fi
+
+ use hires && dobin rfsplat-hd
# utilities
dobin utils/{citydecoder,usgs2sdf,srtm2sdf,postdownload,bearing}
@@ -74,17 +76,16 @@ src_install() {
dodoc CHANGES README utils/fips.txt
newdoc utils/README README.UTILS
- if use doc; then
- dodoc docs/${SPLAT_LANG}/{pdf/splat.pdf,postscript/splat.ps}
- fi
+ use doc && dodoc docs/${SPLAT_LANG}/{pdf/splat.pdf,postscript/splat.ps}
+
#sample data
docinto sample_data
- dodoc sample_data/*
+ dodoc -r sample_data/.
}
pkg_postinst() {
elog "The original SPLAT! command got renamed to 'rfsplat' to avoid"
- elog "filename collission with app-portage/splat."
+ elog "filename collision with app-portage/splat."
elog ""
elog "Be aware that it is still referenced as 'splat' in the documentation."
}