summaryrefslogtreecommitdiff
path: root/sci-electronics/ngspice/ngspice-36.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/ngspice/ngspice-36.ebuild')
-rw-r--r--sci-electronics/ngspice/ngspice-36.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-electronics/ngspice/ngspice-36.ebuild b/sci-electronics/ngspice/ngspice-36.ebuild
index ded8f7f1d8ce..8a616095f439 100644
--- a/sci-electronics/ngspice/ngspice-36.ebuild
+++ b/sci-electronics/ngspice/ngspice-36.ebuild
@@ -40,11 +40,16 @@ DOCS=(
Stuarts_Poly_Notes
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
MULTIBUILD_VARIANTS=( "binaries" )
use shared && MULTIBUILD_VARIANTS+=( "shared" )
use tcl && MULTIBUILD_VARIANTS+=( "tcl" )
- use openmp && tc-check-openmp
}
src_prepare() {