summaryrefslogtreecommitdiff
path: root/sci-electronics/ngspice/ngspice-34.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/ngspice/ngspice-34.ebuild')
-rw-r--r--sci-electronics/ngspice/ngspice-34.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sci-electronics/ngspice/ngspice-34.ebuild b/sci-electronics/ngspice/ngspice-34.ebuild
index 9f70865e81ca..e0f41dc5b269 100644
--- a/sci-electronics/ngspice/ngspice-34.ebuild
+++ b/sci-electronics/ngspice/ngspice-34.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,11 +41,16 @@ DOCS=(
Stuarts_Poly_Notes
)
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
MULTIBUILD_VARIANTS=( "binaries" )
use shared && MULTIBUILD_VARIANTS+=( "shared" )
use tcl && MULTIBUILD_VARIANTS+=( "tcl" )
- use openmp && tc-check-openmp
}
src_prepare() {