summaryrefslogtreecommitdiff
path: root/sci-electronics/magic/files/magic-8.3.232-verbose-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/magic/files/magic-8.3.232-verbose-build.patch')
-rw-r--r--sci-electronics/magic/files/magic-8.3.232-verbose-build.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-electronics/magic/files/magic-8.3.232-verbose-build.patch b/sci-electronics/magic/files/magic-8.3.232-verbose-build.patch
new file mode 100644
index 000000000000..8455d7bb1931
--- /dev/null
+++ b/sci-electronics/magic/files/magic-8.3.232-verbose-build.patch
@@ -0,0 +1,35 @@
+--- a/Makefile
++++ b/Makefile
+@@ -18,12 +18,10 @@
+ all: $(ALL_TARGET)
+
+ standard:
+- @echo --- errors and warnings logged in file make.log
+- @${MAKE} mains 2>&1 | tee -a make.log | egrep -i "(.c:|Stop.|---)"
++ @${MAKE} mains
+
+ tcl:
+- @echo --- errors and warnings logged in file make.log
+- @${MAKE} tcllibrary 2>&1 | tee -a make.log | egrep -i "(.c:|Stop.|---)"
++ @${MAKE} tcllibrary
+
+ force: clean all
+
+@@ -68,7 +66,7 @@
+ install-magic:
+ @echo --- installing executable to $(DESTDIR)${INSTALL_BINDIR}
+ @echo --- installing runtime files to $(DESTDIR)${INSTALL_LIBDIR}
+- @${MAKE} install-real 2>&1 >> install.log
++ @${MAKE} install-real
+
+ install-real: install-dirs
+ for dir in ${INSTALL_CAD_DIRS}; do \
+@@ -89,7 +87,7 @@
+ install-tcl:
+ @echo --- installing executable to $(DESTDIR)${INSTALL_BINDIR}
+ @echo --- installing runtime files to $(DESTDIR)${INSTALL_LIBDIR}
+- @${MAKE} install-tcl-real 2>&1 >> install.log
++ @${MAKE} install-tcl-real
+
+ install-tcl-real: install-tcl-dirs
+ for dir in ${INSTALL_CAD_DIRS} ${PROGRAMS}; do \