summaryrefslogtreecommitdiff
path: root/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild')
-rw-r--r--sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild b/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
index 38be7a2bcdba..28ce47c011f6 100644
--- a/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
+++ b/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-GCONF_DEBUG="no"
+EAPI=7
-inherit autotools epatch flag-o-matic gnome2
+inherit autotools flag-o-matic gnome2
DESCRIPTION="GTK based loudspeaker enclosure and crossovernetwork designer"
HOMEPAGE="http://gspeakers.sourceforge.net/"
@@ -22,20 +21,25 @@ RDEPEND="
|| (
sci-electronics/gnucap
sci-electronics/ngspice
- sci-electronics/spice )
+ sci-electronics/spice
+ )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${P}-cxxflags.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-glib-single-include.patch
+ "${FILESDIR}"/${P}-fix-sigc-includes.patch
+ "${FILESDIR}"/${P}-c++11.patch
+)
+
src_prepare() {
- sed -i -e "s/-O0//" src/Makefile.am
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-glib-single-include.patch
- epatch "${FILESDIR}"/${P}-fix-sigc-includes.patch
- epatch "${FILESDIR}"/${P}-c++11.patch
append-cxxflags '-std=c++11'
mv configure.in configure.ac || die
- eautoreconf
gnome2_src_prepare
+ eautoreconf
}