summaryrefslogtreecommitdiff
path: root/sci-electronics/gsmc/gsmc-1.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gsmc/gsmc-1.1-r2.ebuild')
-rw-r--r--sci-electronics/gsmc/gsmc-1.1-r2.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/sci-electronics/gsmc/gsmc-1.1-r2.ebuild b/sci-electronics/gsmc/gsmc-1.1-r2.ebuild
index ee9e8125fd81..a3da3ce6921a 100644
--- a/sci-electronics/gsmc/gsmc-1.1-r2.ebuild
+++ b/sci-electronics/gsmc/gsmc-1.1-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=8
-inherit autotools epatch
+inherit autotools
DESCRIPTION="A GTK program for doing Smith Chart calculations"
HOMEPAGE="https://www.qsl.net/ik5nax/"
@@ -12,17 +12,20 @@ SRC_URI="https://www.qsl.net/ik5nax/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-CDEPEND="
+DEPEND="
dev-libs/glib:2
- x11-libs/gtk+:2"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}"
+ x11-libs/gtk+:2
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+)
src_prepare() {
- epatch "${FILESDIR}/${P}-autotools.patch"
+ default
eautoreconf
}