summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/Manifest.gzbin8220 -> 8219 bytes
-rw-r--r--sci-chemistry/gperiodic/Manifest2
-rw-r--r--sci-chemistry/gperiodic/files/gperiodic-3.0.3-incompatible-pointers.patch13
-rw-r--r--sci-chemistry/gperiodic/gperiodic-3.0.3-r1.ebuild47
4 files changed, 62 insertions, 0 deletions
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index 9db557cb6e68..898382ae07f2 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ
diff --git a/sci-chemistry/gperiodic/Manifest b/sci-chemistry/gperiodic/Manifest
index 35a2c89303ef..9b40e7b1c8bb 100644
--- a/sci-chemistry/gperiodic/Manifest
+++ b/sci-chemistry/gperiodic/Manifest
@@ -1,3 +1,5 @@
+AUX gperiodic-3.0.3-incompatible-pointers.patch 480 BLAKE2B 18f520b24e789e6167a8dbfda01a1940c38c4bbe47fd245fbb64f44e33572880deb9747a4a80fed85a438cf32e1efc598da3c547aa372f574b02fb287db8fc2a SHA512 8abbdda2882d04c412bef1de387f1c86bfc2ac7edf720239c58e143580f7a8829ea114dc40c981fb749e63e0577e86d0a882f332c0ad4bade5ec36cca6ad6af0
DIST gperiodic-3.0.3.tar.gz 451559 BLAKE2B b91995046b9905a534e3b6f530aee0ad2b4e6ac42cd11755ea182fdaaf8970f34b1aea8a33870abb8767837606a42a0cf0d76c9a689236aa39fba686e1521ee8 SHA512 7226063cf7977f4283a199d4a3d1842d6c9be60c53f5a005541eb26f35cd6538b29f086dc13c28225779e1849a12d1c39150897055c03902cb00adc011bc1ce8
+EBUILD gperiodic-3.0.3-r1.ebuild 945 BLAKE2B 8d1fd608cd13e1749eae7c2c426188bb34652c4428964cd54bed9fc7ef6c9ee2bae592d531b15dccc6cdf6048dd33823b66d44ae6df3d5017820e664f6a3faf7 SHA512 ebcd27c5e79d94ab841d5e270a4c2efbaa686b88201d44b39e44a6d79bab4e2a7e8b0e17bb7117967a61a9628f4ed9f9c89bb5f9eeff0c6c30def5ef67866193
EBUILD gperiodic-3.0.3.ebuild 884 BLAKE2B 3d3389b62f81d204d39f846421fe87267e8cc877464cb7f93bb0355d2ac4e89973e0fff1364f60db9c4ecd38919a774223c0e967ca661835c87e05c1bc83a1b3 SHA512 7e0b3e5b80cb0566489ddeba299d5efceecfcc83ffc7faac61f4d0bfb0aa6bb68dd80cb8452e6e09f1f742a95ab0041e313047741b8be6e6a4ff45c475fc0c4f
MISC metadata.xml 472 BLAKE2B e0811caf393b542123014a9d910fde9c840e2ace704c63073287537a3176ebc8821c1c6603cf6c9fd39bf03f68f77a0778d51632da04e2c5b5daa216188af313 SHA512 6bd33a21ad9298bf9896f0da7b72d0857581255fa4c6e34aa2a133a32e2c91eee43b342138675e60885e65acc3482ea29158138d2695a1acddf6418d6fddc352
diff --git a/sci-chemistry/gperiodic/files/gperiodic-3.0.3-incompatible-pointers.patch b/sci-chemistry/gperiodic/files/gperiodic-3.0.3-incompatible-pointers.patch
new file mode 100644
index 000000000000..b156532e9b54
--- /dev/null
+++ b/sci-chemistry/gperiodic/files/gperiodic-3.0.3-incompatible-pointers.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/919213
+Cast pointer as it is cast everywhere around it
+--- a/gperiodic.c
++++ b/gperiodic.c
+@@ -137,7 +137,7 @@
+ if (col == 0) gtk_label_set_markup (GTK_LABEL (label), _(header.info[row]));
+ else {
+ gtk_label_set_markup (GTK_LABEL (label), _(entry->info[row]));
+- gtk_label_set_selectable (label, TRUE);
++ gtk_label_set_selectable (GTK_LABEL (label), TRUE);
+ }
+
+ gtk_misc_set_alignment(GTK_MISC(label), 0, 0);
diff --git a/sci-chemistry/gperiodic/gperiodic-3.0.3-r1.ebuild b/sci-chemistry/gperiodic/gperiodic-3.0.3-r1.ebuild
new file mode 100644
index 000000000000..6856fce733d8
--- /dev/null
+++ b/sci-chemistry/gperiodic/gperiodic-3.0.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs xdg-utils
+
+DESCRIPTION="Periodic table application for Linux"
+HOMEPAGE="https://sourceforge.net/projects/gperiodic/"
+SRC_URI="https://downloads.sourceforge.net/project/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="
+ sys-libs/ncurses:0
+ x11-libs/gtk+:2
+ x11-libs/cairo[X]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-incompatible-pointers.patch" )
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" "enable_nls=$(usex nls 1 0)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" "enable_nls=$(usex nls 1 0)" install
+ dodoc AUTHORS ChangeLog README
+ newdoc po/README README.translation
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}