summaryrefslogtreecommitdiff
path: root/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild')
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
index b102cd19a244..d100dad51cbc 100644
--- a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
@@ -1,31 +1,30 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
WX_GTK_VER=3.0
-
-inherit autotools eutils wxwidgets
+inherit autotools desktop toolchain-funcs wxwidgets
DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
SRC_URI="https://wxmacmolplt.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE=""
+KEYWORDS="~amd64 ~x86"
RDEPEND="
media-libs/glew:0=
media-libs/mesa[X(+)]
x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-glew.patch )
src_prepare() {
- need-wxwidgets unicode
- epatch "${FILESDIR}"/${P}-glew.patch
+ default
sed \
-e "/^dist_doc_DATA/d" \
-i Makefile.am || die "Failed to disable installation of LICENSE file"
@@ -33,6 +32,9 @@ src_prepare() {
}
src_configure() {
+ tc-export PKG_CONFIG
+
+ setup-wxwidgets unicode
econf \
--with-glew \
--without-ming
@@ -40,6 +42,7 @@ src_configure() {
src_install() {
default
+
doicon resources/${PN}.png
make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
}