summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca/votca-2022.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca/votca-2022.ebuild')
-rw-r--r--sci-chemistry/votca/votca-2022.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/sci-chemistry/votca/votca-2022.ebuild b/sci-chemistry/votca/votca-2022.ebuild
index f59f5347f3de..0962e065f91d 100644
--- a/sci-chemistry/votca/votca-2022.ebuild
+++ b/sci-chemistry/votca/votca-2022.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
-inherit bash-completion-r1 cmake
+inherit bash-completion-r1 cmake python-single-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -25,19 +26,21 @@ HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+gromacs test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
RDEPEND="
!sci-libs/votca-tools
!sci-chemistry/votca-csg
!sci-chemistry/votca-xtp
+ ${PYTHON_DEPS}
app-shells/bash:*
>=dev-cpp/eigen-3.3
dev-libs/boost:=
dev-libs/expat
sci-libs/fftw:3.0=
dev-lang/perl
- gromacs? ( sci-chemistry/gromacs:= )
+ gromacs? ( sci-chemistry/gromacs:=[gmxapi-legacy(+)] )
sci-libs/hdf5[cxx]
sci-libs/libxc
sci-libs/libint:2
@@ -47,6 +50,13 @@ BDEPEND="virtual/pkgconfig"
DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
+src_prepare() {
+ # espressopp was removed from gentoo
+ rm -r ./csg-tutorials/spce/ibi_espressopp || die
+ python_fix_shebang .
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_TESTING=$(usex test)