summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca-xtp/votca-xtp-9999.ebuild')
-rw-r--r--sci-chemistry/votca-xtp/votca-xtp-9999.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild b/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
index fc37002f5a34..d9f436b0316c 100644
--- a/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
+++ b/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
@@ -3,35 +3,33 @@
EAPI=7
-CMAKE_MAKEFILE_GENERATOR="ninja"
+inherit bash-completion-r1 cmake
-inherit bash-completion-r1 cmake multilib
-
-IUSE=""
-if [ "${PV}" != "9999" ]; then
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+else
SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
S="${WORKDIR}/${P#votca-}"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN/-//}.git"
fi
DESCRIPTION="Votca excitation and charge properties module"
-HOMEPAGE="http://www.votca.org"
+HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
+IUSE=""
RDEPEND="
- ~sci-libs/votca-tools-${PV}
>=dev-cpp/eigen-3.3
- sci-libs/hdf5[cxx]
~sci-chemistry/votca-csg-${PV}
- sci-libs/libxc"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ sci-libs/hdf5[cxx]
+ sci-libs/libxc
+ ~sci-libs/votca-tools-${PV}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
DOCS=( README.md NOTICE CHANGELOG.md )