summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca-xtp/votca-xtp-9999.ebuild')
-rw-r--r--sci-chemistry/votca-xtp/votca-xtp-9999.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild b/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
index d9f436b0316c..e4c0b6c8a536 100644
--- a/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
+++ b/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
@@ -19,19 +19,28 @@ HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-cpp/eigen-3.3
~sci-chemistry/votca-csg-${PV}
sci-libs/hdf5[cxx]
+ sci-libs/libecpint
sci-libs/libxc
~sci-libs/votca-tools-${PV}
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-DOCS=( README.md NOTICE CHANGELOG.md )
+DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
pkg_postinst() {
einfo