summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca-xtp/votca-xtp-2021.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca-xtp/votca-xtp-2021.1.ebuild')
-rw-r--r--sci-chemistry/votca-xtp/votca-xtp-2021.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sci-chemistry/votca-xtp/votca-xtp-2021.1.ebuild b/sci-chemistry/votca-xtp/votca-xtp-2021.1.ebuild
deleted file mode 100644
index 4d4db8635e4d..000000000000
--- a/sci-chemistry/votca-xtp/votca-xtp-2021.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 cmake
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN/-//}.git"
-else
- SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux"
- S="${WORKDIR}/${P#votca-}"
-fi
-
-DESCRIPTION="Votca excitation and charge properties module"
-HOMEPAGE="https://www.votca.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-cpp/eigen-3.3
- ~sci-chemistry/votca-csg-${PV}
- sci-libs/hdf5[cxx]
- sci-libs/libxc
- sci-libs/libint:2
- ~sci-libs/votca-tools-${PV}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_TESTING=$(usex test)
- )
- cmake_src_configure
-}
-
-pkg_postinst() {
- einfo
- einfo "Please read and cite:"
- einfo "VOTCA-XTP, J. Chem. Theo. Comp. 14, 6353 (2018)"
- einfo "https://doi.org/10.1021/acs.jctc.8b00617"
- einfo
-}