summaryrefslogtreecommitdiff
path: root/sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild')
-rw-r--r--sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild b/sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild
new file mode 100644
index 000000000000..40ef7c9df2d3
--- /dev/null
+++ b/sci-chemistry/pdbmat/pdbmat-3.89-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake fortran-2
+
+DESCRIPTION="Calculate Tirion's model from pdb structures"
+HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
+SRC_URI="http://ecole.modelisation.free.fr/enm2011.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/Source_ENM2011
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DEXAMPLES=$(usex examples)
+ )
+
+ cmake_src_configure
+}