summaryrefslogtreecommitdiff
path: root/sci-chemistry/pdbcat/pdbcat-1.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pdbcat/pdbcat-1.3-r1.ebuild')
-rw-r--r--sci-chemistry/pdbcat/pdbcat-1.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-chemistry/pdbcat/pdbcat-1.3-r1.ebuild b/sci-chemistry/pdbcat/pdbcat-1.3-r1.ebuild
new file mode 100644
index 000000000000..270e7b98fb36
--- /dev/null
+++ b/sci-chemistry/pdbcat/pdbcat-1.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Manipulate and process PDB files using tools such as Perl, awk, etc"
+HOMEPAGE="http://www.ks.uiuc.edu/Development/MDTools/pdbcat/"
+SRC_URI="http://www.ks.uiuc.edu/Development/MDTools/${PN}/files/${P}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc.patch
+)
+
+DOCS=( README )
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+
+ cmake_src_prepare
+}