summaryrefslogtreecommitdiff
path: root/sci-chemistry/molsketch/molsketch-0.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/molsketch/molsketch-0.7.2.ebuild')
-rw-r--r--sci-chemistry/molsketch/molsketch-0.7.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-chemistry/molsketch/molsketch-0.7.2.ebuild b/sci-chemistry/molsketch/molsketch-0.7.2.ebuild
new file mode 100644
index 000000000000..7dee9f3ea943
--- /dev/null
+++ b/sci-chemistry/molsketch/molsketch-0.7.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="A drawing tool for 2D molecular structures"
+HOMEPAGE="http://molsketch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/Molsketch/${P^}-src.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=sci-chemistry/openbabel-3
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.0-_DEFAULT_SOURCE.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ # fix the doc dir, this is relative to the install dir (i.e. /usr/)
+ -DMSK_INSTALL_DOCS="/share/doc/${PF}"
+ )
+ cmake_src_configure
+}