summaryrefslogtreecommitdiff
path: root/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild')
-rw-r--r--sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild b/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild
deleted file mode 100644
index cdf5b949625f..000000000000
--- a/sci-chemistry/mdtraj/mdtraj-1.9.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="Read, write and analyze MD trajectories with only a few lines of Python code"
-HOMEPAGE="http://mdtraj.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytables[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- sed -e "s:re.match('build.*(mdtraj.*)', output_dir).group(1):'.':g" \
- -i basesetup.py || die
- distutils-r1_python_prepare_all
-}